Modify

Opened 11 years ago

Closed 10 years ago

#747 closed Bug (Wont Fix)

GUI becomes unresponsive on displaying animated Gifs in embedded IE

Reported by: KaFu Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.1 Severity: None
Keywords: Cc:

Description

HiHo Devs,

when I embed an IE into a GUI let it display a large gif / resize a large gif, the GUI suddenly becomes unresponsive. It seems like GUIGetMsg() is stalling out. Oddly, if you fully occlude the GUI it starts polling and processing again.

I compiled to scripts to show the behavior.

http://www.funk.eu/Test_IEDocWriteHTML.zip

Start any of those two, wait for some 5-10 seconds and watch the timestamp writen to console.

Best Regards
KaFu

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by Valik

  • Resolution set to Wont Fix
  • Status changed from new to closed

The problem is Internet Explorer. It apparently has unacceptably poor performance animating GIF images. This causes such a flood of activity that the image is drawn poorly and the host application just can't keep up. Most likely Internet Explorer itself is multi-threaded which allows it's UI to remain responsive even in the face of the message flood the poor GIF animation is causing. AutoIt does not have that luxury and it is a significant rewrite to change it just to work around Microsoft's poor programming.

About all I can say is, hope that IE8 has better GIF rendering because we aren't rewriting AutoIt to accommodate Microsoft's inadequacies at writing a browser. Note that Firefox renders the GIF nice and smoothly without breaking itself in the process. Closing as "Wont Fix".

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.