Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#788 closed Bug (Works For Me)

can't get text from external apps listview

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description

It seems that either this is a bug, doesn't work with all apps, or not supported. I'm assuming it is a bug since I can get the count of items in an external listview.

http://www.autoitscript.com/forum/index.php?showtopic=88293

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by Valik

  • Resolution set to Works For Me
  • Status changed from new to closed

See here for why this ticket is a waste of time.

comment:2 Changed 11 years ago by anonymous

OS: XP SP2
Apps tested on: MS Streets & Trips, Vuze, Encompass, Genesis, Sequoia, Nero Express....Nero did work. Vuze is probably the easiest(free) app for you to get to test it on.
Getting/finding text in Nero works on both ControlListView() and _GUICtrlListView_ text finding/retrieving functions. And both functions don't work on the other apps.

#include <GuiListView.au3>
;#include <ListViewConstants.au3>

;Sleep(2000)

;The control numbers seem to change in Vuze everytime the app is restarted
;$Var1 = ControlGetHandle( "Vuze", "", 2819666 );Downloading listview
$Var1 = ControlGetHandle( "Vuze", "", 591410 );Uploading listview

;========================================================================
;$Var1 = ControlGetHandle( "Nero Express", "", 3591 )
;========================================================================

$Var2 = _GUICtrlListView_GetItemCount($Var1)
ConsoleWrite("!Count " & $Var2 & @CRLF)
If $Var2 > 1 Then
    For $i = 0 To $Var2 - 1
		;------------------------------------------------------------------------------------
		$44 = ControlListView ( "Vuze", "", $Var1, "GetText", $i, 9)
		ConsoleWrite("-C-ListView " & $44 & @CRLF)
		;-------------------------------------------------------------------------------------
		ConsoleWrite(">GC-ListView " & _GUICtrlListView_GetItemTextString($Var1, $i) & @CRLF)
		;-------------------------------------------------------------------------------------
    Next
EndIf

;ControlListView ( "Vuze", "", $Var1, "SelectAll")

All of the other listview functions I've tested works on all the apps.

comment:3 Changed 11 years ago by Valik

If both ControlListView() and _GUICtrlListView_GetItemText() don't work than that's your clue it's not a bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.