Modify

Opened 11 years ago

Closed 11 years ago

#794 closed Bug (No Bug)

Listviews with checkboxes doesn't work "properly"....in my opinion

Reported by: Robert Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description

I'm too lazy right now to take apart my code to show an example, so hopefully what I say is understandable.
I set up a listview in conjunction with a WM_Notify function. When the CELL of the checkbox is clicked, it registers but the box isn't checked, which throws off my function. I believe that if the surrounding cell is clicked the checkbox should be checked as well. If this is not a "bug" I think this should be how it functions...unless there is a specific reason why it isn't like that.

Note: As a workaround I tried to put in the function to check if the checkbox is checked after there is a register on that item and then check it if it isn't checked...so if someone clicks the surrounding cell...but that doesn't work at all.

Attachments (0)

Change History (1)

comment:1 in reply to: ↑ description Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Replying to Robert:

I'm too lazy right now

Then you really don't care about the issue so you shouldn't have posted. Also, you state yourself you are handling WM_NOTIFY which means you are modifying the behavior outside AutoIt's control so it is your responsibility to ensure the default AutoIt handlers are allowed to run and/or ensure whatever functionality you are replacing still works how you want. Very likely this is not a bug. We'd know that for sure if you weren't lazy.

Also see WikiStart before you post in the future.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.