Modify

Opened 11 years ago

Closed 11 years ago

#800 closed Bug (No Bug)

runas from a network path

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description

I have written a script that will elevate an uninstall process to admin credentials. This works nicely when run from a local drive. However when run from a network path, the scripts pauses.

RunAs Command line reads:

RunAs($Admin, @LogonDomain, $AdminPwd,1,@ComSpec & ' /c ' & $RemoveOld)
As I'm using the @ComSpec /c, when running from local drive the command line box appears. When running same script (absolutely no changes) from a network path, this command line box does not appear.

To get around this I have created a .cmd file that copies the script file from the network path to the local drive and run script locally. Bit of a bummer!

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

The user you are running as can not see the network drive. Read the first statement under "Remarks" for RunAs() in the documentation. This is not a bug in AutoIt.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.