Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#82 closed Bug (No Bug)

Variable declared on same line = Undeclared

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.2.10.0 Severity:
Keywords: Cc:

Description

If you try this code:

$str = "Hello" & $str

MsgBox(0, "Test", $str)

you will get an error "$str possibly used before declaration"

I understand this would produce an infinite loop, but the variable is technically declared, is it not?

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by Valik

  • Resolution set to nobug
  • Status changed from new to closed

This is a question. The issue tracker is not the place for asking questions. This is clearly not a bug. The variable is in the process of being declared so of course you can't use it in the declaration because it doesn't exist yet.

Mark as no bug. In the future, please refrain from asking support questions (which belong on the forum) on the issue tracker.

comment:2 Changed 11 years ago by anonymous

I thought it as a bug, and in no way a support question.

I thought the bug was that a declared variable was being marked as undeclared.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.