Modify

Opened 10 years ago

Closed 10 years ago

#824 closed Bug (No Bug)

Long line don't work

Reported by: PlentyWork Owned by: Jos
Milestone: Component: SciTE4AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description (last modified by Jpm)

Tidy crashes when one line is very long ( I think ~2000 chars)
Reproducer:

Global Const $IUnknown_vTable = "ptr QueryInterface; ptr AddRef; ptr Release;"
Global Const $Direct3DDevice9_vTable = $IUnknown_vTable & "ptr TestCooperativeLevel;ptr GetAvailableTextureMem;ptr EvictManagedResources;" & _

"ptr GetDirect3D;ptr GetDeviceCaps;ptr GetDisplayMode;ptr GetCreationParameters;ptr SetCursorParameters;" & _
"ptr SetCursorPosition;ptr ShowCursor;ptr CreateAdditionalSwapChain;ptr GetSwapChain;ptr GetNumberOfSwapChains;" & _
"ptr Reset;ptr Present;ptr GetBackBuffer;ptr GetRasterStatus;ptr SetDialogBoxMode;ptr SetGammaRamp;ptr GetGammaRamp;" & _
"ptr CreateTexture;ptr CreateVolumeTexture;ptr CreateCubeTexture;ptr CreateVertexBuffer;ptr CreateIndexBuffer;" & _
"ptr CreateRenderTarget;ptr CreateDepthStencilSurface;ptr UpdateSurface;ptr UpdateTexture;ptr GetRenderTargetData;" & _
"ptr GetFrontBufferData;ptr StretchRect;ptr ColorFill;ptr CreateOffscreenPlainSurface;ptr SetRenderTarget;ptr GetRenderTarget;" & _
"ptr SetDepthStencilSurface;ptr GetDepthStencilSurface;ptr BeginScene;ptr EndScene;ptr Clear;ptr SetTransform;ptr GetTransform;" & _
"ptr MultiplyTransform;ptr SetViewport;ptr GetViewPort;ptr SetMaterial;ptr GetMaterial;ptr SetLight;ptr GetLight;ptr LightEnable;" & _
"ptr GetLightEnable;ptr SetClipPlane;ptr GetClipPlane;ptr SetRenderState;ptr GetRenderState;ptr CreateStateBlock;ptr BeginStateBlock;" & _
"ptr EndStateBlock;ptr SetClipStatus;ptr GetClipStatus;ptr GetTexture;ptr SetTexture;ptr GetTextureStageState;ptr SetTextureStageState;" & _
"ptr GetSamplerState;ptr SetSamplerState;ptr ValidateDevice;ptr SetPaletteEntries;ptr GetPaletteEntries;" & _
"ptr SetCurrentTexturePalette;ptr GetCurrentTexturePalette;ptr SetScissorRect;ptr GetScissorRect;ptr SetSoftwareVertexProcessing;" & _
"ptr GetSoftwareVertexProcessing;ptr SetNPatchMode;ptr GetNPatchMode;ptr DrawPrimitive;ptr DrawIndexedPrimitive;" & _
"ptr DrawPrimitiveUP;ptr DrawIndexedPrimitiveUP;ptr ProcessVertices;ptr CreateVertexDeclaration;ptr SetVertexDeclaration;ptr GetVertexDeclaration;" & _
"ptr SetFVF;ptr GetFVF;ptr CreateVertexShader;ptr SetVertexShader;ptr GetVertexShader;ptr SetVertexConstantF;ptr GetVertexShaderConstantF;" & _
"ptr SetVertexShaderConstantI;ptr GetVertexShaderConstantI;ptr SetVertexShaderConstantB;ptr GetVertexShaderConstantB;"

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by Jos

  • Description modified (diff)

Works fine for me with:

Tidy AutoIt3 v2.0.26.0   Copyright (c) Jos van der Zande  Februari 6, 2009

What version of Tidy are you using and did you try the latest available Beta?

Jos

comment:2 Changed 10 years ago by Jpm

  • Description modified (diff)
Tidy AutoIt3 v2.0.24.4   Copyright (c) Jos van der Zande  November 30, 2008

which is the 3.3.0 delivered one is working too

comment:3 follow-up: Changed 10 years ago by anonymous

I'm using AutoIt 3.3.0.0 full install with newest SciTE on Windows 7 Beta 32 bit German version.

comment:4 in reply to: ↑ 3 Changed 10 years ago by Jos

Replying to anonymous:

I'm using AutoIt 3.3.0.0 full install with newest SciTE on Windows 7 Beta 32 bit German version.

You forgot to specify the Tidy version you are using.
This is displayed in the SciTE outputpane when you run Tidy(Ctrl+T).
Also check if the latest available Beta version of Tidy has the same issue as I know I have fixed a few issues in resent times.
When you have the latest and greatest and it still crashes then pls provide a test.au3 to allow me to test with the exact same code as you are using.
Jos

Jos

comment:5 Changed 10 years ago by anonymous

Now I got the version:

Tidy AutoIt3 v2.0.24.4   Copyright (c) Jos van der Zande  November 30, 2008

I think this is a Windows 7 issue.
I tried the code in Vista and it works there.
Since Windows 7 is not supported by AutoIt, you may close this issue.
Sorry to involve you. :-(

comment:6 Changed 10 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.