Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#85 closed Bug (Wont Fix)

Scite, 'console' to 'source error line' jumping. (filename issue)

Reported by: M.v.Gulik Owned by: Jos
Milestone: Component: SciTE4AutoIt
Version: Other Severity:
Keywords: scite console filename Cc:

Description

A filename or path with '('...')' text,
virtually disables the 'console error message' to 'source error line' jumping feature in scite4autoit.

Scite4AutoIt v2008.01.26
(AutoIt v3.2.10.0/v3.2.11.0, WinXp-Pro-sp2)

;; filename: 'File with () bug.au3'
Opt("MustDeclareVars", 1)
$True = True
$False = False

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by Valik

  • Resolution set to wontfix
  • Status changed from new to closed

This is not a bug and even if it was there's nothing we could do about it anyway since we don't maintain SciTE. What happens is the lexer is confused by the unexpected () in the path-name and thinks it's a line number or some other token it recognizes. The simple solution is, don't use files with () in the name.

Resolving as wontfix since I agree that it is ideal but also I know we can't fix it and that it's highly unlikely the SciTE maintainer will fix it.

comment:2 Changed 11 years ago by Valik

That should, of course, read "I agree that it is NOT ideal".

comment:3 Changed 11 years ago by TicketCleanup

  • Version set to Other

Automatic ticket cleanup.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.