Modify

Opened 10 years ago

Closed 10 years ago

#854 closed Bug (Fixed)

InetGetSize

Reported by: psandu.ro Owned by:
Milestone: 3.3.1.0 Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description

#include <Inet.au3>
$a = InetGetSize("http://address/version.dat")
If $a > 0 Then

_INetGetSource('www.google.com')
$b = InetGetSize("http://" & $user & ":" & $pass & "@address/download/fis.upd"
MsgBox(262144, 'Size:', $b)

EndIf

-without _INetGetSource('www.google.com')

always $b=0

why?
pls help
thanks.

Attachments (1)

Test.au3 (1.2 KB) - added by Jpm 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Valik

Please read WikiStart. We must be able to reproduce an issue to fix it.

comment:2 Changed 10 years ago by Jpm

added test script email by psandu.ro

for me the script work with or without the _InetGetSource

Changed 10 years ago by Jpm

comment:3 Changed 10 years ago by Jpm

  • Resolution set to Works For Me
  • Status changed from new to closed

comment:4 follow-up: Changed 10 years ago by Jpm

  • Resolution Works For Me deleted
  • Status changed from closed to reopened

reopen as the test must be done thru a proxy as diagnose by psandu.ro

comment:5 in reply to: ↑ 4 Changed 10 years ago by Valik

Replying to Jpm:

reopen as the test must be done thru a proxy as diagnose by psandu.ro

If that is true then we need more details.

comment:6 Changed 10 years ago by Valik

  • Milestone set to 3.3.1.0
  • Resolution set to Fixed
  • Status changed from reopened to closed

I'm going to go out on a limb and say this is fixed in 3.3.1.0 (the beta we'll eventually release). When fixing another proxy-related issue I discovered that InetGetSize() did not go through a proxy at all. In 3.3.1.0 this has been fixed.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.