Modify

Opened 10 years ago

Closed 10 years ago

#870 closed Bug (Works For Me)

Floating point error.

Reported by: jaenster Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description (last modified by Valik)

Code:

#include <date.au3>
$timestamp = string(_DateDiff( 's',"1970/01/01 00:00:00",_NowCalc()))
consolewrite($timestamp&@crlf)

Error:
Mircosoft Visual C++ Runtime libary:
Program: C:\program files\autoit3\autoit3.exe
R6002

  • Floating point support not loaded.

For a year or something i get this error now (I get it on 3 diffrent machine's).
I guess it have something to do with writing a varable that contains only numbers (like $timestamp).

Note, I use windows xp sp2 on a amd 1ghz

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by Valik

  • Description modified (diff)

comment:2 Changed 10 years ago by Valik

  • Does this happen when you compile the script or run it through AutoIt3.exe?
  • If compiled, do you use UPX on the script?
  • Are the machines identical images?

This is not a bug in AutoIt. This is either something broken on your machine or an external program breaking the AutoIt binary.

comment:3 Changed 10 years ago by Valik

  • Resolution set to Works For Me
  • Status changed from new to closed

Closing due to lack of information.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.