Modify

Opened 10 years ago

Closed 10 years ago

#880 closed Bug (No Bug)

Run RunWait Error with Working Dir Parameter

Reported by: mleo2003@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description

When trying to run a script located in the ScriptDir, if your working directory is changed, the Run() function will not work with those files until you use FileChangeDir() to set the working dir back.

A test script is attached, MsgBox.exe is just a simple AutoIt compiled script, with just a message box saying "It worked...", for testing. The issue won't show up if you save the sample script & program to your My Documents folder, the folder it changes to has to not be the same as the directory your file is saved in.

Attachments (1)

BugTest.au3 (621 bytes) - added by mleo2003@… 10 years ago.
Sample Script

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by mleo2003@…

Sample Script

comment:1 Changed 10 years ago by Jos

Not sure what you thing the BUIG is, but the Workdir parameter ísn't used to find the program being shelled.

comment:2 Changed 10 years ago by Jos

Let me try that again but this time without so many typos :)

Not sure what you think the BUG is, but the Workdir parameter ísn't used to find the program being shelled.

comment:3 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Nothing to see here. Definitely not a bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.