Modify

Opened 10 years ago

Closed 10 years ago

#890 closed Bug (No Bug)

inconsistence with objects and execute

Reported by: JRSmile Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description

Hi if i use the execute function to do a method call like this:
Execute($object.'&$method&'(somemorestuff)')
it works, but when i use the execute like this:
Execute($object.'&$method&' = "this is a test"')
it doesn't work.
example attached.

Attachments (1)

testsdf.au3 (1.2 KB) - added by JRSmile 10 years ago.
example of execute and objects

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by JRSmile

example of execute and objects

comment:3 Changed 10 years ago by anonymous

Environment = 3.3.0.0 under WIN_XP/Service Pack 3 X86

comment:4 Changed 10 years ago by JRSmile

back again, just recogniced that it is impossible to set object attributes with execute because it is a read only function, i would suggest adding this as feature request for further autoit versions.

what do you think?

comment:5 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

You missed the point which was the script is not reproduceable. You are using an object not commonly available.

what do you think?

I think Execute() should be removed from the language.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.