Modify

Opened 10 years ago

Closed 10 years ago

#903 closed Bug (Duplicate)

_ExcelReadSheetToArray doesn't work with other MSoffice language than US

Reported by: rooversj@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: Cc:

Description

When the OS language or MS Office language is other than US the function _ExcelReadSheetToArray might not work correctly. Because of the letter "C" in the functioncode mentioned below. For example "Column" in Dutch is "Kolom" so when I change the "C" into "K" the function magically will work on my pc (Dutch OS en Dutch MS Office) because "lR1C1" in the Dutch version of Excel is "lR1K1".

	; Extract integer last row and col
	Local $iLastRow = StringInStr($sLastCell, "R")
	Local $iLastColumn = StringInStr($sLastCell, "C")
	$iLastRow = Number(StringMid($sLastCell, $iLastRow + 1, $iLastColumn - $iLastRow - 1))
	$iLastColumn = Number(StringMid($sLastCell, $iLastColumn + 1))

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by Valik

  • Resolution set to Duplicate
  • Status changed from new to closed

Closing as duplicate of #850. A simple search for "_ExcelReadSheetToArray" would have provided results.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.