Modify

Opened 10 years ago

Closed 10 years ago

#921 closed Bug (Wont Fix)

AutoIt is retrieving wrong values from Data Base (AS400 Data Base)

Reported by: mmahima Owned by: Jpm
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: DB2 Cc:

Description (last modified by Valik)

When i try to execute the following statements in autoit, it is retrieving wrong values from database, could any one help.

$sqlCon = objCreate("ADODB.Connection")
$objRecordSet = ObjCreate("ADODB.RecordSet")
$sqlCon.Open("Provider='IBMDA400';Data Source = '10.0.1.25';User Id='USERNAME'; password='Password';")
$oRs = $sqlCon.Execute("select * FROM ccdata.rcmast where MSACT# = '8217'")
MSGBOX(0,"",$oRs.Fields("MSACT#").value)

Expected values is 8217, whereas it is retrieving 6213.

I tried using VBseditor for executing the above statement, vbseditor is retrieving correct from database whereas autoit is displaying wrong values.

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by TicketCleanup

  • Milestone 3.3.1.0 deleted

Automatic ticket cleanup.

comment:2 Changed 10 years ago by Jpm

Not sure some dev can help you as db2 is not a database use by default in our environment.
Can you reproduce with MSAccess database for instance?

comment:3 Changed 10 years ago by Valik

  • Description modified (diff)

Please read WikiStart on how to create a good ticket. You're making this overly difficult.

comment:4 Changed 10 years ago by Jpm

  • Owner set to Jpm
  • Status changed from new to assigned

comment:5 Changed 10 years ago by Jpm

  • Resolution set to Wont Fix
  • Status changed from assigned to closed

I close it as I can't reproduce.
Please reopen with something we can reproduce in our tests.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jpm.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.