Modify

Opened 10 years ago

Closed 10 years ago

#982 closed Bug (Duplicate)

Checkbox backcolor in tab

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.3.1.0 Severity: None
Keywords: Cc:

Description (last modified by Valik)

#include <ButtonConstants.au3>
#include <GUIConstantsEx.au3>
#include <TabConstants.au3>
#include <WindowsConstants.au3>

$Form1 = GUICreate("Form1", 500, 300, 192, 50)
$Checkbox0 = GUICtrlCreateCheckbox("work", 130, 24, 185, 65)
$Tab1 = GUICtrlCreateTab(120, 120, 305, 169)
GUICtrlSetResizing(-1, $GUI_DOCKWIDTH+$GUI_DOCKHEIGHT)
$TabSheet1 = GUICtrlCreateTabItem("TabSheet1")
$TabSheet2 = GUICtrlCreateTabItem("TabSheet2")
GUICtrlSetState(-1,$GUI_SHOW)
;not work in tab.(backcolor)
$Checkbox1 = GUICtrlCreateCheckbox("not work", 130, 150, 60, 12 )
$Checkbox2 = GUICtrlCreateCheckbox(@AutoItVersion, 130, 176, 60, 12 )
GUICtrlSetBkColor(-1,0xffffff)
GUICtrlCreateTabItem("")
GUISetState(@SW_SHOW)

While 1
	$nMsg = GUIGetMsg()
	Switch $nMsg
		Case $GUI_EVENT_CLOSE
			Exit
	EndSwitch
WEnd

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by anonymous

worked in 3.3.1.0

comment:2 Changed 10 years ago by anonymous

worked in 3.3.0.0. but 3.3.1.0 not work.

comment:3 Changed 10 years ago by MrCreatoR <mscreator@…>

I thinks it's already has been reported: GUICtrlCreateCheckbox() on tabs.

And fixed :)

comment:4 Changed 10 years ago by Valik

  • Description modified (diff)
  • Resolution set to Duplicate
  • Status changed from new to closed

Closing as a duplicate of #975.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.