Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#985 closed Bug (Fixed)

errors in der helpfile for AutoIt 3.3.1.0 Beta

Reported by: Tweaky Owned by: Valik
Milestone: 3.3.1.1 Component: Documentation
Version: 3.3.1.0 Severity: None
Keywords: Cc:

Description

Hi,
we have translate the english helpfile into german.
So we see that some errors are in der the english helpfile.

Here ist an example what I mean (from 3.3.0.0)

here an example:
13 PixelSearch Number of variables wrong / variables differently / variables in different order (is | should) 4 | 8

Syntax:
PixelSearch ( left, top, right, bottom, color [, shade-variation [, step [, hwnd]]] )

Parameters:
left
top
right
bottom
colour
shade-variation
step
hwnd

4 | 8 means that the parameter 1, 2, 3 and 4 are identical in the syntax an the parameter list.
Parameter 5 ist wrong. Here it is only a write error (color <> colour)

here an example:
70 _GUICtrlListView_SimpleSort Number of variables wrong / variables differently / variables in different order (is | should) 2 | 3

Syntax:
_GUICtrlListView_SimpleSort($hWnd, ByRef $vDescending, $iCol)

Parameters:
$hWnd
$vDescending

2 | 3 means that the parameter 1 and 2 are identical in the syntax an the parameter list.
Parameter 3 is missing.

If you don`t know what I mean, please look here
http://www.autoitscript.com/trac/autoit/ticket/877

Attachments (1)

errors 3.3.1.0 Beta.txt (3.4 KB) - added by Tweaky 10 years ago.
File with errors

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Tweaky

File with errors

comment:1 Changed 10 years ago by Gary

1st off need to report bugs separately.

As far as I can tell from the convoluted description of the bug for _GUICtrlListView_SimpleSort, it's not a bug.

comment:2 Changed 10 years ago by Tweaky

Hi,
its only an example with _GUICtrlListView_SimpleSort.
I will only show what the numbers in my txt-file means

What does ou mean with "1st off need to report bugs separately."???

comment:3 Changed 10 years ago by Valik

  • Milestone set to 3.3.1.1
  • Owner set to Valik
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in version: 3.3.1.1

comment:4 Changed 10 years ago by Valik

Could you please add a check in a future version to ensure that optional parameters have the "[optional]" tag. I forgot to add that tag for some of the changes which made me realize we've probably forgot to add it in a lot of places.

comment:5 Changed 10 years ago by Tweaky

I have change my testscript.
I will open a new Ticket

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Valik.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.