Jump to content

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Find out more here. X
X


Photo

Au3Forums v1.1


  • Please log in to reply
71 replies to this topic

#1 McGod

McGod

    Formerly Chip

  • Active Members
  • PipPipPipPipPipPip
  • 589 posts

Posted 23 December 2006 - 09:51 AM

Au3Forums
Current Version: v1.1
Next Release: v2.0

Au3Forums is a highly dynamic forum system that uses Autoit and a web server to create the ultimate forum experience.
The system is highly modular, meaning you can add/remove functions fairly easily.
Features:

  • Full user authenticate system (Register, Login, Logout)
  • Full Forum and Category functions (Full Subforum system)
    • Post/Delete/Edit/Close/Open/Sticky Topic functions
    • BBCode system
  • Group system
  • Skinning function(Have multiple skins and have the option to allow users to choose)
  • Languages(Have multiple languages users can choose from)
  • Full Admin CP
  • Personal Message System
  • Profiles
  • Moderation
RED = Will be in v2.0
ORANGE = Is partical in v1.1 But will be full in v2.0

Attached File  Au3Forums.rar   324.05KB   834 downloads
Attached File  Au3Forums_v1.1.zip   195.43KB   311 downloads

Demo Link(See v2.0 in developer state(May not always be functioning))
Link


Edited by Chip, 10 May 2007 - 10:42 PM.








#2 James

James

    Universalist

  • MVPs
  • 10,363 posts

Posted 23 December 2006 - 09:53 AM

What does this do? Sorry I'm not on my laptop with autoit to test it.

#3 McGod

McGod

    Formerly Chip

  • Active Members
  • PipPipPipPipPipPip
  • 589 posts

Posted 23 December 2006 - 10:03 AM

Look @ Demo Link (Should work)

#4 James

James

    Universalist

  • MVPs
  • 10,363 posts

Posted 23 December 2006 - 10:09 AM

Ahh right. Thats pretty cool. I'm guessing this is like a web au3 program

#5 PartyPooper

PartyPooper

    Universalist

  • Active Members
  • PipPipPipPipPipPip
  • 689 posts

Posted 23 December 2006 - 11:12 AM

Going by the demo, very nice, very clean interface. Don't know if Jon would every consider using it for the AutoIt forums, but it'd certainly be cool to see it used as such (after it's been developed further I mean).

#6 James

James

    Universalist

  • MVPs
  • 10,363 posts

Posted 23 December 2006 - 11:17 AM

By the way, I can't signup.

#7 NELyon

NELyon

    Do you wanna brew my avatar?

  • Active Members
  • PipPipPipPipPipPip
  • 3,526 posts

Posted 23 December 2006 - 01:01 PM

I too get an autoit error when trying to sign up. But other that that, amazing program.

#8 Zedna

Zedna

    AutoIt rulez!

  • MVPs
  • 8,794 posts

Posted 23 December 2006 - 02:20 PM

Demo link looks VERY nice :P

#9 NELyon

NELyon

    Do you wanna brew my avatar?

  • Active Members
  • PipPipPipPipPipPip
  • 3,526 posts

Posted 23 December 2006 - 02:29 PM

Ok, i tried to set up a demo. I had to edit alot, but i get an index now. If i click Login or Register, it says something like:

HTTP/1.1 200 OK Content-Type: text/html nameis not a defined variable

codemyster.zapto.org/forum/index.au3

Edited by D-Generation X, 23 December 2006 - 02:30 PM.


#10 McGod

McGod

    Formerly Chip

  • Active Members
  • PipPipPipPipPipPip
  • 589 posts

Posted 23 December 2006 - 05:52 PM

Ok, i tried to set up a demo. I had to edit alot, but i get an index now. If i click Login or Register, it says something like:

HTTP/1.1 200 OK Content-Type: text/html nameis not a defined variable

codemyster.zapto.org/forum/index.au3


Did you run the installer? check the very top the of the index.au3 for "Global configpath" and see if the location is right. That means that your forums arent connecting with the sqlite db.

Fixed register error.

Edited by Chip, 23 December 2006 - 05:53 PM.


#11 theguy0000

theguy0000

    Benevolent Dictator

  • Active Members
  • PipPipPipPipPipPip
  • 3,750 posts

Posted 23 December 2006 - 06:00 PM

started messing with your demo, and noticed two things:

1.) put in email confirmation!!
2.) the forum allows registration of multiple users under the same email address

ill post back if i see more
The cake is a lie.www.theguy0000.com is currentlyUP images.theguy0000.com is currentlyUP all other *.theguy0000.com sites are DOWN

#12 theguy0000

theguy0000

    Benevolent Dictator

  • Active Members
  • PipPipPipPipPipPip
  • 3,750 posts

Posted 23 December 2006 - 06:14 PM

topics should probably be organized from newest to oldest (newest on top)
The cake is a lie.www.theguy0000.com is currentlyUP images.theguy0000.com is currentlyUP all other *.theguy0000.com sites are DOWN

#13 McGod

McGod

    Formerly Chip

  • Active Members
  • PipPipPipPipPipPip
  • 589 posts

Posted 23 December 2006 - 06:39 PM

I need to figure out a method of Categorize Posts by date

#14 _Kurt

_Kurt

    been a while hasn't it

  • Active Members
  • PipPipPipPipPipPip
  • 865 posts

Posted 23 December 2006 - 08:45 PM

Also, once everything is working, add in:
Group: .
Posts: .
Joined: .
From: .
Member No.: .
Awaiting Diablo III..

#15 arcker

arcker

    Universalist

  • Active Members
  • PipPipPipPipPipPip
  • 581 posts

Posted 23 December 2006 - 09:26 PM

really nice, and i just love the look : simple and clear
if doesn't seem to be all in autoit, so it's really impressive
waiting for nexyt release ^^

-- Arck System _ Soon -- Ideas make everything

"La critique est facile, l'art est difficile"

 

Projects :

  • Au3Service : Run your exe as service V3 / Updated 29/07/2013 Get it Here

#16 NELyon

NELyon

    Do you wanna brew my avatar?

  • Active Members
  • PipPipPipPipPipPip
  • 3,526 posts

Posted 23 December 2006 - 09:33 PM

Ok, i got it working GREAT. Just one thing: Maybe you should make it so you have to register before posting my default. Other that that, do you mind if i use this for my sites main forum?

#17 James

James

    Universalist

  • MVPs
  • 10,363 posts

Posted 23 December 2006 - 09:34 PM

Why can I not sign up?

#18 McGod

McGod

    Formerly Chip

  • Active Members
  • PipPipPipPipPipPip
  • 589 posts

Posted 23 December 2006 - 09:48 PM

Why can I not sign up?

What does it say?
You sign up here:http://aforums.hopto.org/Au3Forums/index.au3?act=register

Ok, i got it working GREAT. Just one thing: Maybe you should make it so you have to register before posting my default. Other that that, do you mind if i use this for my sites main forum?

It is, you have to login to post. Sure you can use it as your forums. You don't have to ask :P

#19 NELyon

NELyon

    Do you wanna brew my avatar?

  • Active Members
  • PipPipPipPipPipPip
  • 3,526 posts

Posted 23 December 2006 - 10:31 PM

ugh... i got it to register now. It doesn't confirm it though. If i log in with a correct username/password, it silently fails to login. It does however, recognize an incorrect username/password combo

Edited by D-Generation X, 23 December 2006 - 10:31 PM.


#20 McGod

McGod

    Formerly Chip

  • Active Members
  • PipPipPipPipPipPip
  • 589 posts

Posted 23 December 2006 - 10:38 PM

ugh... i got it to register now. It doesn't confirm it though. If i log in with a correct username/password, it silently fails to login. It does however, recognize an incorrect username/password combo


I could use some fake mailer thing, but it would get blocked too much.
I registered, I noticed one of the bugs i fixed for my current vers(Ill update in sec), logging in IS case Sensitive so it will error.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users