Jump to content

Windows 7 64-bit Autoitx3.control

Recommended Posts

Just downloaded and installed autoit3 on Windows 7 64-bit. I wrote a "hello.au3" which runs fine. But when I tried windows script host:

set oautoit=wscript.createobject("autoitx3.control")

I get an error message that the control cannot be created.

I also successfully did regsvr32 c:\program files (x86)\autoit3\autoitx\autoitx3.dll which didn't fix the error message.

I also reinstalled autoit, and did not check the box that says "use native x64 tools where possible".

Still not able to write a .vbs with the above line that executes without error.

Any suggestions?


Link to post
Share on other sites

Haha, I solved my own question.

And the answer is::::::::

I had to do a regsvr32 C:\Program Files (x86)\AutoIt3\AutoItX\autoitx3_x64.dll

Now, how do I change the name of this topic to:

(Solved) Windows 7 64-bit Autoitx3.control? Or does the moderator do dat?

Link to post
Share on other sites


Only thing at the bottom of my post is MultiQuote and Quote. That's just bizarre.

Wow, an icon for "Edit" just showed up in this post, to the left of "MultiQuote", but it is not in a button, and it is very faint.

But I don't have the "Edit" icon on the very first post, where the topic needs to be changed.

Edited by cmpyutr
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...