Jump to content

AutoIT script crashes on runwait console app


Recommended Posts

We have run into an issue calling a console command (makeiso.exe). When opening the command prompt and calling the application from there it works fine.

When using an autoit scipt using the same command it results in a reboot of the PC. We have tried to use the comspec command but also this results in a reboot.

Other commands run fine, we have had the same result with miso.exe (magic iso).

Both commands are used to create iso files from the command line.

This is the command we used and crashed the PC:

$val = RunWait("d:\xplode\basic_install\wpi\common\makeiso.exe -J -r -V -v -o d:\backup.iso -graft-points -path-list d:\xplode\basic_install\wpi\common\test2.txt",@SW_MAXIMIZE)

the text file test2.txt contains the graft points and contains 2 lines:

adobe=d:\xplode\basic_install\adobe

dvdtools=d:\xplode\basic_install\dvdtools

In addition the same results when calling a batch file that contains the same line as in the script when calling from autit crashes the PC.

Does anyone have any suggestions? is this a bug?

Link to post
Share on other sites

This is the command we used and crashed the PC:

$val = RunWait("d:\xplode\basic_install\wpi\common\makeiso.exe  -J -r -V -v -o d:\backup.iso -graft-points -path-list d:\xplode\basic_install\wpi\common\test2.txt",@SW_MAXIMIZE)

With this line, you have @SW_MAXIMIZE as your working directory parameter.

Perhaps should be as below

$val = RunWait("d:\xplode\basic_install\wpi\common\makeiso.exe -J -r -V -v -o d:\backup.iso -graft-points -path-list d:\xplode\basic_install\wpi\common\test2.txt", "",@SW_MAXIMIZE)

Looking at what is a project folder? Are you using magiciso.exe, to make an iso, while it is within the compilation itself?

Edit grammer

Edited by MHz
Link to post
Share on other sites

My version:

;%CD% equals the current working directory. Which is in this example: "d:\xplode\basic_install\wpi\common"
$Arguments = "-J -r -V -v -o d:\backup.iso -graft-points -path-list %CD%\test2.txt"
$val = RunWait(@ComSpec & " /c %CD%\makeiso.exe " & $Arguments, "d:\xplode\basic_install\wpi\common", @SW_MAXIMIZE)
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...