Modify

Opened 10 years ago

Closed 10 years ago

#1192 closed Bug (Works For Me)

Tidy.exe crashes - when long strings are assinged again?

Reported by: Bowmore Owned by: Jos
Milestone: Component: Other
Version: 3.3.1.1 Severity: None
Keywords: Tidy.exe Cc:

Description

Environment = 3.3.1.1 under WIN_XP/Service Pack 2 X86
When running Tidy on Tidy_Crash.au3 Tidy crashes. The commented out assingments to $sNew and $sExisting are identical to the 2 above. Tidy crashes still crashes if the second assingments to $sNew and $sExisting are uncommented, but if they are removed from the file Tidy runs with no problem.

The strings I'm assinging are quite long but well within AutIts limits.

I have attached 2 simple files to demonstrate the issue

Scite outout from crashing version

>"C:\Autoit3\Scite\tidy\tidy.exe" "C:\AutoIt3Data\Scripts\Bug Reports\Tidy_Crash.au3"
Tidy AutoIt3 v2.0.28.6   Copyright (c) Jos van der Zande  August 7, 2009
>Exit code: -1073741819    Time: 1.985

Scite outout from non-crashing version

>"C:\Autoit3\Scite\tidy\tidy.exe" "C:\AutoIt3Data\Scripts\Bug Reports\Tidy_No_Crash.au3"
Tidy AutoIt3 v2.0.28.6   Copyright (c) Jos van der Zande  August 7, 2009
+> Tidy AutoIt3 finished. Original copied to:"C:\AutoIt3Data\Scripts\Bug Reports\BackUp\Tidy_No_Crash_old11.au3"
>Exit code: 0    Time: 0.338

Attachments (2)

Tidy_No_Crash.au3.gz (1.0 KB) - added by Bowmore 10 years ago.
gzipped error reproduction script Tidy_No_Crash.au3
Tidy_Crash.au3.gz (1.3 KB) - added by Bowmore 10 years ago.
gzipped error reproduction script

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Bowmore

gzipped error reproduction script Tidy_No_Crash.au3

Changed 10 years ago by Bowmore

gzipped error reproduction script

comment:1 Changed 10 years ago by Jos

  • Owner set to Jos
  • Status changed from new to accepted

I have downloaded both and tested it with Tidy v2.0.28.6 and it doesn't crash.
Does it crash for you each time you run Tidy?

Jos

comment:2 Changed 10 years ago by Bowmore

Running Tidy on Tidy_crash.au3 crashes every time for me. I've just tried it on a different laptop at home running Win XP SP3 with exactly the same result. I downloaded the files from trac to be certain that the file I had posted was displaying the problem.

I not sure if this is any help to you but I have Visual Studio 6 on this laptop which picks up the error as.

---------------------------
Microsoft Visual C++
---------------------------
Unhandled exception in Tidy.exe: 0xC0000005: Access Violation.
---------------------------
OK   
---------------------------

and the debugger indicates the error to be at the address indicated by the arrow below.

   0040EB64   mov         ecx,ebx
   0040EB66   and         ecx,3
   0040EB69   je          0040EB6D
-->0040EB6B   rep movs    byte ptr [edi],byte ptr [esi]
   0040EB6D   emms
   0040EB6F   sfence
   0040EB72   mov         eax,dword ptr [esp+10h]

This bug is not causing me any great problems, but it's always nice to track down the cause of unexplained crashes where possible.

Thanks
Bowmore

comment:3 Changed 10 years ago by Jos

  • Resolution set to Works For Me
  • Status changed from accepted to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.