Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1195 closed Bug (No Bug)

Control key sticks down when using HotKeySet i.e. Cntl d

Reported by: blackja@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.0.0 Severity: None
Keywords: sticky hotkey Cc:

Description

The control key sticks in the down position when using Hotkeyset with control d (or other keys). Found originally in v. 3.3.1.1 but problem exists in 3.3.0.0 also.

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

No it doesn't. If you want to be taken seriously next time provide an example that reproduces the problem.

comment:2 in reply to: ↑ 1 Changed 11 years ago by JimBlack

Replying to Valik:

No it doesn't. If you want to be taken seriously next time provide an example that reproduces the problem.

;
I appreciate your need to be able to reproduce the problem. I will try to reproduce the problem in something smaller than the 8000 line program I have written. If I can't reproduce it smaller would you be interested in looking at the problem in the 8000 line program with the associated SQL database? In twenty years of programing I have lived to learn with small bugs in programs I need, especially when working with something as good as Autoit. Thanks

comment:3 follow-up: Changed 11 years ago by Valik

But the thing is: There's not a bug here. The most likely cause is you are using Send() inside a HotKeySet() callback function. There are a few other things you could be doing that lock the keyboard state unexpectedly. It should be trivial to reproduce and it should be obvious it's not a bug when you see just what it is.

comment:4 in reply to: ↑ 3 Changed 11 years ago by anonymous

Replying to Valik:

But the thing is: There's not a bug here. The most likely cause is you are using Send() inside a HotKeySet() callback function. There are a few other things you could be doing that lock the keyboard state unexpectedly. It should be trivial to reproduce and it should be obvious it's not a bug when you see just what it is.

As usual you are correct. I am using a send command to automate entering the date in an GUIcntrl input box. I did not realize you could not do this. I tried to reproduce it in the example file for the GUI control input box but it worked flawlessly. My Mistake, sorry for abusing your time.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.