Modify

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#1197 closed Bug (No Bug)

IniReadSection Limitation

Reported by: Emiel Wieldraaijer Owned by:
Milestone: Component: Documentation
Version: 3.3.0.0 Severity: None
Keywords: InReadSection Limit Array Cc:

Description

Hi,

I don't know if its a bug or if it's by design, but IniReadSection can only retrieve 99 keys.. maybe it should be mentioned in the documentation.

Best regards,

Emiel

(Valik don't shoot me)

Attachments (0)

Change History (6)

comment:1 follow-up: Changed 11 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Prove it. Otherwise, you're running into the 32kb per section limit, not some arbitrary key limit that doesn't exist.

comment:2 in reply to: ↑ 1 Changed 11 years ago by anonymous

Replying to Valik:

Prove it. Otherwise, you're running into the 32kb per section limit, not some arbitrary key limit that doesn't exist.

In the helpfile of 3.3.0.0 there is mentioned:

Only the first 32767 chars are taken in account in an section due to Win9x compatibility.

But from version 3.3.0.0 there was dropped support for Win9x OS systems.
So I think in helpfile should be updated these remarks to current situation.

comment:3 Changed 11 years ago by Zedna

previous reply was from me (Zedna).
I filled my name but it was somehow changed to anonymous :-(

comment:4 Changed 11 years ago by Valik

But the limitation didn't change...

comment:5 Changed 10 years ago by anonymous

will this limitation be removed?

comment:6 Changed 10 years ago by anonymous

It still needs to be proven to exist in the first place.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.