Modify

Opened 10 years ago

Closed 6 years ago

#1198 closed Feature Request (Rejected)

User tray items auto-checkmarking

Reported by: Rob Saunders <therks@…> Owned by: Valik
Milestone: Component: AutoIt
Version: Severity: None
Keywords: trayitem Cc:

Description

Sorry for the clumsily worded title.
Repro. script:

Opt('TrayAutoPause', 0)
TrayCreateItem('Click me')

While 1
	Sleep(1000)
WEnd

When you click "Click Me" it check marks it. I never told it to do this and, though I might be missing something, I can't figure out how to make it stop. I don't believe this is the proper behaviour.

Environment = 3.3.1.1 under WIN_XP/Service Pack 2 X86

Attachments (0)

Change History (12)

comment:1 Changed 10 years ago by Valik

I too found it difficult to figure out how to disable the behavior. This is definitely not something that should be default behavior.

comment:2 Changed 10 years ago by wraithdu

Opt('TrayMenuMode', 2)

This Opt will stop the behavior, though the Opt description in the help file doesn't clearly convey the effect.

comment:3 Changed 10 years ago by Rob Saunders <therks@…>

Odd, I could've sworn I tried that and it didn't work. Still shouldn't be the default behaviour though.

comment:4 Changed 10 years ago by BinaryBrother

Using Opt('TrayMenuMode',2) causes "Script Paused" and the default Tray-items for an AutoIt script to be shown in my tests. I didn't manage to disable the checks at all, without causing defaults to be added to the tray menu.

AutoIt Ver.: 3.3.1.1
NT 6.1 (Windows 7) x64

comment:5 Changed 10 years ago by Rob Saunders <therks@…>

If you read the help, it states that 1 is to disable the default menu, so combine 1 with 2.
ie: Opt('TrayMenuMode', 1+2)

comment:6 Changed 10 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

No bug just se the rigth Opt('TrayMenuMode', ...)

comment:7 Changed 10 years ago by Valik

  • Resolution No Bug deleted
  • Status changed from closed to reopened

The problem is, we have to set the magical combination of correct options. It's poorly designed and is needlessly confusing. Something needs addressed here because two otherwise competent individuals (at least) were puzzled about the behavior.

comment:8 Changed 10 years ago by Jpm

  • Type changed from Bug to Feature Request

comment:9 Changed 10 years ago by Jpm

Is not so magical but yes there is 2 different options that currently have to be understood

Opt('TrayAutoPause', 0)	; to avoid script pause
Opt('TrayMenuMode', 2)	; to avoid user item checkmarking

that does not seem too much but well ...

comment:10 Changed 10 years ago by TicketCleanup

  • Version 3.3.1.1 deleted

Automatic ticket cleanup.

comment:11 Changed 10 years ago by Jpm

  • Owner set to Valik
  • Status changed from reopened to assigned

comment:12 Changed 6 years ago by Jon

  • Resolution set to Rejected
  • Status changed from assigned to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Valik.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.