Modify

Opened 10 years ago

Closed 10 years ago

#1223 closed Bug (Fixed)

_GUICtrlStatusBar_EmbedControl() Failing in beta

Reported by: Beege Owned by: Jpm
Milestone: 3.3.1.4 Component: AutoIt
Version: 3.3.1.3 Severity: None
Keywords: Cc:

Description

The example given in the documentation will produce the error I keep getting. I think the problem is originating in _memread() fuction, but im not sure.

C:\Program Files\AutoIt3\beta\Include\GuiStatusBar.au3 (257) : ==> Subscript used with non-Array variable.:
Local $iBarX = $aRect[0]
Local $iBarX = $aRect ERROR

Attachments (0)

Change History (2)

comment:1 in reply to: ↑ description Changed 10 years ago by anonymous

Replying to Beege:

The example given in the documentation will produce the error I keep getting. I think the problem is originating in _memread() fuction, but im not sure.

C:\Program Files\AutoIt3\beta\Include\GuiStatusBar.au3 (257) : ==> Subscript used with non-Array variable.:
Local $iBarX = $aRect[0]
Local $iBarX = $aRect ERROR

Sorry, not memread(), _GUICtrlStatusBar_GetRectEx() is whats setting @Error.

comment:2 Changed 10 years ago by Jpm

  • Milestone set to 3.3.1.4
  • Owner set to Jpm
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in version: 3.3.1.4

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jpm.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.