Modify

Opened 10 years ago

Closed 10 years ago

#1390 closed Bug (No Bug)

ControListView causes Microsoft Management Console to crash (32bit/64bit problem).

Reported by: frosgate@… Owned by:
Milestone: Component: Aut2Exe
Version: 3.3.2.0 Severity: None
Keywords: Cc:

Description

script:

ShellExecute("services.msc")
Do
 sleep(250)
Until WinExists("[TITLE:Services; CLASS:MMCMainFrame]")
$text=ControlListView("[TITLE:Services; CLASS:MMCMainFrame]", "", "[CLASS:SysListView32]","GetText",2,0)

output from _DebugBugReportEnv()

Environment = 3.3.0.0 X64 under  WIN_VISTA X64

When the script is compiled as 32bit (the default) it causes the Microsoft Management Console to crash. When compiled as 64bit, there is no issue.

I know the obvious solution is to compile the code as 64bit, and that solution solves my problem, but I thought I'd let you all know that I had run into this.

I'd like to say thank you for the many years of work that have obviously gone into developing autoit: it is an amazing tool that I am grateful for every day.

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by frosgate@…

I just noticed that I was using an outdated version of autoit. Updated to 3.3.2.0, and the problem is resolved. The ticket can be closed. Sorry for the inconvenience.

comment:2 Changed 10 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.