Modify

Opened 10 years ago

Closed 8 years ago

#1631 closed Feature Request (Rejected)

Get FilePath from file handle

Reported by: evilertoaster Owned by: Jon
Milestone: Component: AutoIt
Version: Severity: None
Keywords: Cc:

Description

I had previously sent this as a cod submission via the method described here: http://www.autoitscript.com/autoit3/files/coders/submission_spec.txt

But it appears support@… is no longer a valid email address according to the yahoo mailer daemon... Regardless, here was the email:



In relation to this post: http://www.autoitscript.com/forum/index.php?showtopic=114541

The solution is trivial, (I've attached a code submission implementing it)... but so is the issue itself.
Because of the nature of 'includes' in AutoIt there's not much practicality to providing this function, but it may have use in plugins or ActiveX/COM where you may be trying to get the FilePath from a handle given to you by non-public code.

Attachments (1)

AU3-Evilertoaster-2010-05-18.zip (144.2 KB) - added by Evilertoaster 10 years ago.

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by Evilertoaster

comment:1 Changed 10 years ago by Evilertoaster

This should be a feature request, not a bug... I can't seem to edit the ticket type after I made it...

comment:2 Changed 10 years ago by Jpm

  • Type changed from Bug to Feature Request

comment:3 Changed 10 years ago by TicketCleanup

  • Version 3.3.6.0 deleted

Automatic ticket cleanup.

comment:4 Changed 10 years ago by Jpm

  • Resolution set to Rejected
  • Status changed from new to closed

as a solution can be done with a UDF using GetFinalPathNameByHandle windows API.
We don't plan to extend AutoIt builtin function.

comment:5 follow-up: Changed 10 years ago by evilertoaster

A solution cannot be done with that API. GetFinalPathNameByHandle() only works on the Windows API HANDLE structs. The request was for this ability on native AutoIt handles, which use standard FILE* structs.

comment:6 in reply to: ↑ 5 Changed 10 years ago by Jpm

  • Resolution Rejected deleted
  • Status changed from closed to reopened

Replying to evilertoaster:

A solution cannot be done with that API. GetFinalPathNameByHandle() only works on the Windows API HANDLE structs. The request was for this ability on native AutoIt handles, which use standard FILE* structs.

I read a liitle too fast the forum.
I will reopen it to get feedback from other Dev's

comment:7 Changed 10 years ago by Jpm

  • Owner set to Jon
  • Status changed from reopened to assigned

comment:8 follow-up: Changed 8 years ago by guinness

Last edited 8 years ago by guinness (previous) (diff)

comment:9 in reply to: ↑ 8 Changed 8 years ago by Jpm

Replying to guinness:

This is an Example of how to achieve this using native code - http://www.autoitscript.com/forum/topic/134578-filenamebyhandle-find-a-filepath-using-the-handle-returned-by-fileopen/.

It is not using native code as comment 5 request it

comment:10 Changed 8 years ago by trancexx

  • Resolution set to Rejected
  • Status changed from assigned to closed

This really isn't necessary.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.