Modify

Opened 10 years ago

Closed 9 years ago

#1746 closed Bug (Fixed)

Controls not found in moving from 3.3.4.0 to 3.3.6.0

Reported by: paul.seccombe@… Owned by: Jon
Milestone: 3.3.7.7 Component: AutoIt
Version: 3.3.6.0 Severity: None
Keywords: Controls Cc:

Description

First off - thanks for a great piece of software.
I recently upgraded to the lastest version (3.3.6.1) but the AutoIt Info window could no longer identify the indiviual controls in the application I use (sorry I can't give you any further info on the application as it is an internal one used by the business I work for). I have back tracked through old versions of AutoIt and found that the problem started in verison 3.3.6.0 and 3.3.4.0 works fine.
If there are any screen shots or backdoor tests you want me to run to find the problem please let me know.
Thanks.

Attachments (3)

screen.png (170.6 KB) - added by Daniel 10 years ago.
3-3-4-0.PNG (35.7 KB) - added by Daniel 10 years ago.
3-3-6.1.PNG (36.2 KB) - added by Daniel 10 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 10 years ago by Jpm

Difficult to help you at least post screen shot of what is working and what it is not if you can ?
You are not following the ticket submission requirement perhaps better to go to forum first to get help.

comment:2 Changed 10 years ago by Jpm

you can even check when the change occurs downloading the beta http://www.autoitscript.com/autoit3/files/beta/autoit/archive/autoit-v3.3.5.3-sfx.exe which only solve #1444 not the #1391

comment:3 Changed 10 years ago by Jpm

  • Owner set to Jon
  • Status changed from new to assigned

comment:4 Changed 10 years ago by daniel

First off - thanks for a great piece of software.
I have the same problem.
AutoIt Info window:
ver 3.3.6.0 -> not working fine
ver 3.3.6.1 -> not working fine
ver 3.3.5.3 beta -> not working fine
ver 3.3.4.0 -> -> working fine
If there are any screen shots or backdoor tests you want me to run to find the problem please let me know.
Thanks.

comment:5 Changed 10 years ago by Jpm

We just need a repro script not just a report saying that something is not working
as I say please post scrren shots explaining the difference.
I am sure you can do better to post a repro script

Changed 10 years ago by Daniel

comment:6 follow-up: Changed 10 years ago by Daniel

Hello again,
i have made a scrennshot and i hope, this will help.
The screenshot is made with version 3.3.4.0 from AutoIt v3 Windows Info.
With version 3.3.4.0 i can find the Button (Button23 with the ID 1416).
With a version above 3.3.4.0 e.g. version 3.3.6.1 i can not find this Button.
I do not know what is a repro script. My english is not so good, sorry.
Kind regards.

comment:7 Changed 10 years ago by mvg

Forum case If you ask me.

comment:8 in reply to: ↑ 6 ; follow-up: Changed 10 years ago by Jpm

Replying to Daniel:

Hello again,
i have made a scrennshot and i hope, this will help.
The screenshot is made with version 3.3.4.0 from AutoIt v3 Windows Info.
With version 3.3.4.0 i can find the Button (Button23 with the ID 1416).
With a version above 3.3.4.0 e.g. version 3.3.6.1 i can not find this Button.
I do not know what is a repro script. My english is not so good, sorry.
Kind regards.

a repro script is a script which reproduce the error
I think that it is still needed to understand the problem as with the screen shot I cannot figure out how all control are created.
The best as mention by @mvg is best to go to forum first to get help unless your report allow to reproduce the error if any.

comment:9 in reply to: ↑ 8 Changed 10 years ago by Daniel

Hello,
the error is not in the script i wrote.
I have only the software (not the source code) i want to control and i use the AutoIt v3 Windows Info tool to find out the IDs of the buttons i want to click.
And i can only find the IDs with the tool ver. 3.3.4.0 and not with a version above.
The Error is in the Windows Info tool and so i think i can not make a repro script.
Kind regards

comment:10 follow-up: Changed 10 years ago by Jpm

are you saying the sofware you use is not written in AutoIt Code and I cannot have a copy to reproduce the behavior you get?

comment:11 in reply to: ↑ 10 Changed 10 years ago by anonymous

Hello,
i use AutoIt to write a script to control the software "Argus on PC". You can see it in the screenshot i made. "Argus on PC" is a software which is not written by me and it need a special external hardware device. "Argus on PC" is not written in AutoIT Code. So i use the AutoIt Windows Info tool to get the IDs of the Buttons from "Argus on PC" (the software i want to control) to control the software. And this is what works fine with the version 3.3.4.0 from the AutoIt Windows Info tool. I think this is the same problem as the problem what paul (first text) explained. I want to help to find the differences in the AutoIt Windows Info tool from version 3.3.4.0 to 3.3.6.1, but i do not know how i can help.
Kind regards

Changed 10 years ago by Daniel

Changed 10 years ago by Daniel

comment:12 Changed 10 years ago by Daniel

Hello,
i have found a software with that you can reproduce it. Please have a look at the screenshots. The software i want to control is "Putty". (www.putty.org)(http://the.earth.li/~sgtatham/putty/latest/x86/putty.exe) I want to identify the "delete" Button. In version 3.3.4.0 from the AutoIt Windows Info tool i can identify the Button12 (ID 1060) in the version 3.3.6.1 from the AutoIt Windows Info tool i can not identify this Button. I hope this will help you.
Kind regardes
Daniel

comment:13 Changed 10 years ago by mvg

Seems the Group control is blocking.
Button1 and Button2 can't be targeted with the current Au3Info. (Ps: don't know about older version of Au3Info.)

#include <ButtonConstants.au3>
#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>

#region ### START Koda GUI section ### Form=
Local $Form1 = GUICreate("Form1", 369, 233, 192, 114)
Local $Button1 = GUICtrlCreateButton("Button1", 232, 64, 75, 25)
Local $Button2 = GUICtrlCreateButton("Button2", 232, 104, 75, 25)
Local $Group1 = GUICtrlCreateGroup("Group1", 8, 8, 337, 209)
GUICtrlCreateGroup("", -99, -99, 1, 1)
GUISetState(@SW_SHOW)
#endregion ### END Koda GUI section ###

Do
Until GUIGetMsg() = $GUI_EVENT_CLOSE

comment:14 Changed 10 years ago by mvg

PS2: (was a little to fast) If the Group control is actually used as expected. There is no problem targeting button1 and button2. (moved first GUICtrlCreateGroup from below button2 to above button1.)

Local $Form1 = GUICreate("Form1", 369, 233, 192, 114)
Local $Group1 = GUICtrlCreateGroup("Group1", 8, 8, 337, 209)
Local $Button1 = GUICtrlCreateButton("Button1", 232, 64, 75, 25)
Local $Button2 = GUICtrlCreateButton("Button2", 232, 104, 75, 25)
GUICtrlCreateGroup("", -99, -99, 1, 1)

comment:15 Changed 10 years ago by Daniel

Hello,
i think it is a bug in the AutoIt Windows Info tool in version 3.3.6.0 and above. Because i think the AutoIt Windows Info tool is to identify buttons from programs wich are not written in AutoIt code. AutoIt is a great Tool to control other programs. And to do this you must be able to identify the buttons from other programs.
Kind regards.
Daniel

comment:16 Changed 10 years ago by Jpm

Thanks now Jon can correct what he did #1444

comment:17 Changed 9 years ago by Jon

  • Milestone set to 3.3.7.7
  • Resolution set to Fixed
  • Status changed from assigned to closed

Fixed by revision [6084] in version: 3.3.7.7

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.