Modify

Opened 9 years ago

Closed 9 years ago

#1751 closed Bug (No Bug)

Ctrl key stuck after send containing ^ if BlockInput is on

Reported by: mkaidor@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.0 Severity: None
Keywords: Cc:

Description (last modified by Jpm)

If BlockInput is on when a send function is called containing a carrot modifier, the Ctrl key will be stuck on. This was fixed by switching to send( "{ctrlup}foo{ctrldown}" ). Regardless, it really ought to work with send( "\carrot\foo" ). I used the word "carrot" since an actual carrot causes some of the text to superscript in the preview.

Cuplrit code:

Func CtrlSend9(  )
	Send( "\carrot\9" )
EndFunc

Func HatchGoIterate( $n )
	Send(  $n & $n & "x" )
	MouseClick( "Left" )
EndFunc

Func HatchStartAuto(  )

	;Start blocking input todai
	BlockInput( 1 )


	;Get Mouse Position
	$Pos = MouseGetPos(  )

	;Stop what I'm doing 
	MouseMove( 150 , 150 , 0 )
	Send( "{SHIFTDOWN}" )
	MouseClick( "LEFT" )
	Send( "{SHIFTUP}" )

;- THE PROBLEM IS HERE 
	;Remember camera position and selected group
	CtrlSend9(  )
	Send( "\carrot\{INSERT}" )


	;Center the mouse
	MouseMove( 960 , 470 , 0 )

	;Do It
	For $Group = 8 To 5 Step -1
		HatchGoIterate( $Group  )
	Next

	;Stop and go to last important thing 
	Send( "{INSERT}9" ) 
	MouseMove( $Pos[0] , $Pos[1] , 0 )


	;Give me back input
	BlockInput( 0 )

EndFunc

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by Jpm

  • Description modified (diff)

comment:2 Changed 9 years ago by Jpm

I don't understand your repro script as \carrot is not interpreted by Send()
even \{INSERT} just send 2 keys \ and {INSERT] as \9 is sending \ and 9
Please correct your script with an application I can work with
;)

comment:3 Changed 9 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

Terrible bug report that doesn't demonstrate anything.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.