Modify

Opened 10 years ago

Closed 10 years ago

#1752 closed Bug (Wont Fix)

GUICtrlCreateIcon doesn't work with higher index than 0 in WinXP x64 / Win 2003

Reported by: JFX Owned by: Jon
Milestone: Component: AutoIt
Version: 3.3.6.1 Severity: None
Keywords: Cc:

Description

None of the Icons create with GUICtrlCreateIcon will be display under XP x64 (compiled as x86 or x64)

Seems to work fine with XP x86 / Win7 x64

GUICreate("", 600, 250)
For $Y = 1 To 4
    For $X = 1 To 4
        GUICtrlCreateIcon('shell32.dll',$x + $y * 4 -4, 5+$X*74-64, 5+$Y*64-64, 32, 32)
        GUICtrlCreateButton("",300+$X*74-64,5+$Y*64-64,42,42,0x8040)
        GUICtrlSetImage(-1, 'shell32.dll',$x + $y * 4 -4)
    Next
Next

GUISetState()

While 1
    $msg = GUIGetMsg()
        If $msg = -3 Then ExitLoop
WEnd
GUIDelete()

Same problem seems to be with Win 2003. Maybe also similar issue with
GUICtrlSetImage

related topic
http://www.autoitscript.com/forum/index.php?showtopic=119151&pid=828393&st=0&#entry828393

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by Jpm

  • Owner set to Jon
  • Status changed from new to assigned

I cannot repro your problem as I don't have access to WinXP/64 or Win2003.

For the .icl I don't know what have change but it is true it is not working anymore since a lot of AutoIt releases. Certainly the support of ordinal numbering have change the behavior.

comment:2 Changed 10 years ago by Jpm

In fact I retest the related topic and found that .icl is working under Win7

comment:3 Changed 10 years ago by Jpm

I get access to a WinXP64 and I can confirm that The Windows API used for GUICtrlCreateIcon has been fixed by Microsoft (LoadImage)
The difference with Button CtrlSetImage is the fact an extractIcon is used which allow to have the right centering in a button but using 16x16 or 32x32 icon.
As Win7 and Vista as been Fixed by Microsoft, I will not do any change to AutoIt code
Sorry for this non fixing
Perhaps a global reengineering of GUI see #376 will change this behavior for this old Windows X64 release

comment:4 Changed 10 years ago by Jpm

  • Resolution set to Wont Fix
  • Status changed from assigned to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.