Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1822 closed Bug (Wont Fix)

_GUICtrlListView_GetCounterPage???

Reported by: Mat Owned by: Gary
Milestone: Component: Standard UDFs
Version: 3.3.6.1 Severity: None
Keywords: Cc:

Description

Ummm... Is there a reason for the ridiculous naming of this function?

_GUICtrlListView_GetCount*P*erPage

It works fine (using send message with LVM_GETCOUNTPERPAGE) so it must be a typo, followed by a lot of people not noticing. It even says "ListView Get Counter Page" in the example.

Mat

Attachments (0)

Change History (7)

comment:1 follow-up: Changed 10 years ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

You right at was certainly a typo at the creation time 9/2007 but as it can lead to regression to existing script we don't plan to change it

comment:2 in reply to: ↑ 1 ; follow-up: Changed 10 years ago by Zedna

Replying to Jpm:

You right at was certainly a typo at the creation time 9/2007 but as it can lead to regression to existing script we don't plan to change it

I disagree.
It should be fixed because there are many other script breaking changes
and similar typo in function name was already fixed:

http://www.autoitscript.com/trac/autoit/ticket/1015
Ticket #1015 (closed Bug: Fixed)
_SQLite_SaveMode() --> _SQLite_SafeMode()

comment:3 in reply to: ↑ 2 Changed 10 years ago by Jpm

Replying to Zedna:

Replying to Jpm:

You right at was certainly a typo at the creation time 9/2007 but as it can lead to regression to existing script we don't plan to change it

I disagree.
It should be fixed because there are many other script breaking changes
and similar typo in function name was already fixed:

http://www.autoitscript.com/trac/autoit/ticket/1015
Ticket #1015 (closed Bug: Fixed)
_SQLite_SaveMode() --> _SQLite_SafeMode()

on this #1015 I was the designer so I have taken the responsability of breaking . but on this one is not me.
Can you post on main forum an question about this breaking and report the conclusion if any?
Thanks.

PS I think a lot of UDF are never used ...

comment:4 Changed 10 years ago by Mat

I posted it on the forum here when I found it... I don't think it is used at all, as doing a search of the forum doesn't bring up any results other than a few people posting the name changes for the UDF between versions.

Even if it is left as is, there should at least be a note saying what it actually is, would have saved Kafu a bit of time by the looks of it :)

comment:5 Changed 10 years ago by Jpm

  • Resolution No Bug deleted
  • Status changed from closed to reopened

comment:6 Changed 10 years ago by Jpm

  • Resolution set to Wont Fix
  • Status changed from reopened to closed

comment:7 Changed 10 years ago by BrewmanNH

In reading over this bug report, I'm wondering if there couldn't be a new function added to the LV UDF that uses the exact same function and just names it correctly?

This way, there's no script breaking changes made. Also in the help file you could either put a disclaimer in that mentions that the misspelled function is a deprecated feature and have a reference to the new _GUICtrlListView_GetCountPerPage function, or just leave both functions in the help file and hope no one notices that they're the same function. Just a thought that should make everyone happy, and make it easier for people to find the function if they're looking for a function that does what it does.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Gary.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.