Modify

Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#1935 closed Bug (Works For Me)

_IEBodyReadText with IE9 failed

Reported by: Jpm Owned by:
Milestone: Component: AutoIt
Version: 3.3.6.1 Severity: None
Keywords: Cc:

Description (last modified by Jpm)

with some .htm it returns a string of 1 length instead of the expected one.
IE8 is OK

#include <IE.au3>

Local $oIE = _IECreate()
_IENavigate($oIE, "file://" & @ScriptDir & "\testgoodfile.htm", 1)
Local $fullText = _IEBodyReadText($oIE)
_IEQuit($oIE)
MsgBox(0, "Results", "AutoIt version =" & @AutoItVersion & @CRLF & "length of $fullText = " & StringLen($fullText))


Attachments (1)

testgoodfile.htm (3.6 KB) - added by Jpm 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by Jpm

comment:1 follow-up: Changed 10 years ago by Jpm

  • Description modified (diff)

comment:2 Changed 10 years ago by DaleHohm

I cannot reproduce the problem on Win 7 32-bit, AutoIt 3.3.6.1. The Sring length returned is as expected.

Can others reproduce?

Dale

comment:3 in reply to: ↑ 1 Changed 10 years ago by Jpm

Replying to Jpm:
I suppose you get a length around 2500.
what can i do on my system in fact 2 Win7 32-bit sp1
both return 1

comment:4 Changed 10 years ago by Jon

  • Resolution set to Works For Me
  • Status changed from new to closed

comment:5 Changed 10 years ago by Jpm

any clue to understand what is going under my 2 systems ...

comment:6 Changed 10 years ago by Jpm

Finally the suggestion #1938 of using #RequireAdmin is a workaround.
The ticket should be reopen to work witout #RequireAdmin or tell me what I need to change in IE9 configuration

comment:7 Changed 10 years ago by Jpm

At least Jon, reproduce the problem
IE8 seems to failed too.

Last edited 10 years ago by Jpm (previous) (diff)

comment:8 Changed 10 years ago by DaleHohm

Again, suggest you test with VBS:

set oIE = CreateObject("InternetExplorer.Application")
oIE.visible=1
oIE.navigate2("file:///C:\temp.html")
Wscript.sleep 6000
MsgBox(oIE.document.body.innerText)

Dale

comment:9 Changed 8 years ago by Jpm

Finally I found how to have it working disabling the Protected Mode on Internet security zone.

Look a little strange that local file follow the same rule as the Internet ones but why not

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.