Modify

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#222 closed Bug (Fixed)

GUIRegisterMsg() and callback function "chains"

Reported by: Ultima Owned by: Jpm
Milestone: 3.2.11.11 Component: AutoIt
Version: 3.2.11.9 Severity: None
Keywords: Cc:

Description

It looks like there might be a bug/regression in the betas with regards to GUIRegisterMsg(), though I'm not exactly sure when the regression occurred. I've attached an example script (sorry it's a tad bit long, but it's simple).

As is, it behaves correctly, and the treeview root can't be expanded by double-click. On the other hand, if you return anything, anywhere in the callback function chain, AutoIt decides it wants to handle the message, regardless of what is returned, and regardless of whether the return value even bubbles up back to the original callback function.

Regarding the function chain, ignore the For loops. I only added them to demonstrate the fact that it isn't because the function chain is taking too long to return that causes AutoIt to behave wonkily (it's something I considered at first).

Attachments (2)

GUIRegisterMsg_Regression.au3 (1.7 KB) - added by Ultima 12 years ago.
GUIRegisterMsg_Regression_Part2.au3 (2.3 KB) - added by Ultima 11 years ago.
(2008-05-08)

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Ultima

comment:1 Changed 11 years ago by Jpm

  • Milestone set to 3.2.11.11
  • Owner set to Jpm
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in version: 3.2.11.11

Changed 11 years ago by Ultima

(2008-05-08)

comment:2 Changed 11 years ago by Ultima

Something still seems amiss here... I've attached an example where the fix still doesn't work. The problem here seems to lie with the WM_GETMINMAXINFO message. If it's not registered, there doesn't appear to be any problem with forcing AutoIt to *not* handle WM_NOTIFY. This is not an issue under 3.2.10.0.

Note: I might have also noticed another problem where the double-click expands/collapses the treeview item the *first* time it occurs, but not on any subsequent double-clicks. I couldn't reproduce it reliably, though, so I decided to report this one first. One problem at a time :o

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jpm.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.