Modify

Opened 12 years ago

Closed 12 years ago

#223 closed Bug (Duplicate)

GUIRegisterMsg() callback documentation...

Reported by: Ultima Owned by:
Milestone: Component: Documentation
Version: 3.2.11.9 Severity: None
Keywords: Cc:

Description

The GUIRegisterMsg() documentation needs updating. It's difficult to determine what return value would cause AutoIt to stop handling the message internally.

From the manual:

By using 'Return' without any return value the AutoIt internal message handler (if there is one for this message) will NOT be proceed!

Yet, an empty return *does* allow AutoIt to continue handling the message. Returning 0 does the same. It seems that it's only when you return a non-zero integer that it stops handling things internally.

So yeah, clarification/reorganization would be nice :)

Additionally, the example script no longer works properly (though that problem might originate from the possible regression described in ticket #222)...

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to Duplicate
  • Status changed from new to closed

The documentation is correct, the behavior is bugged and it is related to your other ticket. AutoIt is supposed to stop processing the message if you use the "Return" keyword, period. The only exception to that rule is if you use "Return $GUI_RUNDEFMSG" which is the only way to use Return *and* allow AutoIt to use it's own internal handler.

I'm closing this as a Duplicate of #222. There is no bug in the documentation, just in AutoIt.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.