Modify

Opened 5 years ago

Closed 5 years ago

#2566 closed Bug (Fixed)

"global" cursor in GUISetCursor fails.

Reported by: steinar@… Owned by: Jon
Milestone: 3.3.11.0 Component: AutoIt
Version: 3.3.9.25 Severity: None
Keywords: Cc:

Description

Setting the override flag in GUISetCursor() does not work in latest beta. When hovering another control autoit defaults to the cursor id of that control.

Example script:
#include <ButtonConstants.au3>
#include <GUIConstantsEx.au3>
$Form1 = GUICreate("Form1", 615, 438, 192, 124)
$Button1 = GUICtrlCreateButton("Button1", 64, 56, 89, 33)
$Button2 = GUICtrlCreateButton("Button2", 272, 56, 89, 33)
GUISetState(@SW_SHOW)
GUISetCursor(15, 1, $Form1)

While 1

$nMsg = GUIGetMsg()
Switch $nMsg

Case $GUI_EVENT_CLOSE

Exit

Case $Button1

GUISetCursor(2, 1, $Form1)

Case $Button2

GUISetCursor(15, 1, $Form1)

EndSwitch

WEnd

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 5 years ago by Jpm

I don't think we can say it is not working.

You can see as soon the cursor leave the button area the new cursor is updated

The fix in the beta solve CPU hoggin.

comment:2 in reply to: ↑ 1 Changed 5 years ago by steinar@…

Replying to Jpm:

I don't think we can say it is not working.

You can see as soon the cursor leave the button area the new cursor is updated

The fix in the beta solve CPU hoggin.

How is this not a bug? The cursor shouldn't change over a control at all when using the override flag. Run this script in 3.3.8.1 and see how it behaves differently.

comment:3 Changed 5 years ago by Jpm

For sure it behave differently but the new behavior without CPU Hogging seems OK for me.

comment:4 Changed 5 years ago by Jon

  • Milestone set to 3.3.11.0
  • Owner set to Jon
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed by revision [9475] in version: 3.3.11.0

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.