Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2649 closed Bug (Wont Fix)

AutoIt3 Source Obfuscator v1.0.31.1 bug

Reported by: anonymous Owned by:
Milestone: Component: Other
Version: 3.3.10.2 Severity: None
Keywords: Cc:

Description

0.02 ==> Start Add_Include: Include_Rec$:#include <GuiRichEdit.au3>
0.02 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\guirichedit.au3
0.02 ==> Start Add_Include: Include_Rec$:#include "EditConstants.au3"
0.02 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\editconstants.au3
0.02 ==> Start Add_Include: Include_Rec$:#include "FileConstants.au3"
0.02 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\fileconstants.au3
0.02 ==> Start Add_Include: Include_Rec$:#include "RichEditConstants.au3"
0.02 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\richeditconstants.au3
0.03 ==> Start Add_Include: Include_Rec$:#include "StructureConstants.au3"
0.03 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\structureconstants.au3
0.11 ==> Start Add_Include: Include_Rec$:#include "Clipboard.au3"
0.11 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\clipboard.au3
0.11 ==> Start Add_Include: Include_Rec$:#include "Memory.au3"
0.11 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\memory.au3
0.11 ==> Start Add_Include: Include_Rec$:#include "MemoryConstants.au3"
0.11 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\memoryconstants.au3
0.11 ==> Start Add_Include: Include_Rec$:#include "StructureConstants.au3"
0.11 ==> Skipped, Already included:"StructureConstants.au3"
0.11 ==> Start Add_Include: Include_Rec$:#include "ProcessConstants.au3"
0.11 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\processconstants.au3
0.11 ==> Start Add_Include: Include_Rec$:#include "Security.au3"
0.11 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\security.au3
0.11 ==> Start Add_Include: Include_Rec$:#include "SecurityConstants.au3"
0.11 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\securityconstants.au3
0.11 ==> Start Add_Include: Include_Rec$:#include "WinAPIError.au3"
0.11 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\winapierror.au3
0.14 ==> Start Add_Include: Include_Rec$:#include "Misc.au3"
0.14 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\misc.au3
0.14 ==> Start Add_Include: Include_Rec$:#include "FontConstants.au3"
0.14 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\fontconstants.au3
0.14 ==> Start Add_Include: Include_Rec$:#include "StructureConstants.au3"
0.14 ==> Skipped, Already included:"StructureConstants.au3"
0.14 ==> Start Add_Include: Include_Rec$:#include "WinAPIError.au3"
0.14 ==> Skipped, Already included:"WinAPIError.au3"
0.16 ==> Start Add_Include: Include_Rec$:#include "SendMessage.au3"
0.16 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\sendmessage.au3
0.16 ==> Start Add_Include: Include_Rec$:#include "UDFGlobalID.au3"
0.16 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\udfglobalid.au3
0.16 ==> Start Add_Include: Include_Rec$:#include "WinAPI.au3"
0.16 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\winapi.au3
0.16 ==> Start Add_Include: Include_Rec$:#include "WinAPIConstants.au3"
0.16 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\winapiconstants.au3
0.17 ==> Start Add_Include: Include_Rec$:#include "StructureConstants.au3"
0.17 ==> Skipped, Already included:"StructureConstants.au3"
0.17 ==> Start Add_Include: Include_Rec$:#include "FileConstants.au3"
0.17 ==> Skipped, Already included:"FileConstants.au3"
0.17 ==> Start Add_Include: Include_Rec$:#include "Security.au3"
0.17 ==> Skipped, Already included:"Security.au3"
0.17 ==> Start Add_Include: Include_Rec$:#include "SendMessage.au3"
0.17 ==> Skipped, Already included:"SendMessage.au3"
0.17 ==> Start Add_Include: Include_Rec$:#include "WinAPIError.au3"
0.17 ==> Skipped, Already included:"WinAPIError.au3"
0.33 ==> Start Add_Include: Include_Rec$:#include <Inet.au3>
0.33 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\inet.au3
0.33 ==> Start Add_Include: Include_Rec$:#include "WinAPI.au3"
0.33 ==> Skipped, Already included:"WinAPI.au3"
0.33 ==> Start Add_Include: Include_Rec$:#include "Date.au3"
0.33 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\date.au3
0.33 ==> Start Add_Include: Include_Rec$:#include "Memory.au3"
0.33 ==> Skipped, Already included:"Memory.au3"
0.33 ==> Start Add_Include: Include_Rec$:#include "WinAPI.au3"
0.33 ==> Skipped, Already included:"WinAPI.au3"
0.33 ==> Start Add_Include: Include_Rec$:#include "StructureConstants.au3"
0.33 ==> Skipped, Already included:"StructureConstants.au3"
0.33 ==> Start Add_Include: Include_Rec$:#include "Security.au3"
0.33 ==> Skipped, Already included:"Security.au3"
0.38 ==> Start Add_Include: Include_Rec$:#include "InetConstants.au3"
0.38 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\inetconstants.au3
0.39 ==> Start Add_Include: Include_Rec$:#include <Crypt.au3>
0.39 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\crypt.au3
0.39 ==> Start Add_Include: Include_Rec$:#include "FileConstants.au3"
0.39 ==> Skipped, Already included:"FileConstants.au3"
0.41 ==> Start Add_Include: Include_Rec$:#include <TipText.au3>
0.41 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\tiptext.au3
0.41 ==> Start Add_Include: Include_Rec$:#include <GuiConstants.au3>
0.41 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\guiconstants.au3
0.41 ==> Start Add_Include: Include_Rec$:#include "GUIConstantsEx.au3"
0.41 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\guiconstantsex.au3
0.41 ==> Start Add_Include: Include_Rec$:#include "AVIConstants.au3"
0.41 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\aviconstants.au3
0.41 ==> Start Add_Include: Include_Rec$:#include "ButtonConstants.au3"
0.41 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\buttonconstants.au3
0.41 ==> Start Add_Include: Include_Rec$:#include "ComboConstants.au3"
0.41 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\comboconstants.au3
0.42 ==> Start Add_Include: Include_Rec$:#include "DateTimeConstants.au3"
0.42 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\datetimeconstants.au3
0.42 ==> Start Add_Include: Include_Rec$:#include "EditConstants.au3"
0.42 ==> Skipped, Already included:"EditConstants.au3"
0.42 ==> Start Add_Include: Include_Rec$:#include "ListBoxConstants.au3"
0.42 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\listboxconstants.au3
0.42 ==> Start Add_Include: Include_Rec$:#include "ListViewConstants.au3"
0.42 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\listviewconstants.au3
0.44 ==> Start Add_Include: Include_Rec$:#include "ProgressConstants.au3"
0.44 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\progressconstants.au3
0.44 ==> Start Add_Include: Include_Rec$:#include "RichEditConstants.au3"
0.44 ==> Skipped, Already included:"RichEditConstants.au3"
0.44 ==> Start Add_Include: Include_Rec$:#include "SliderConstants.au3"
0.44 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\sliderconstants.au3
0.44 ==> Start Add_Include: Include_Rec$:#include "StaticConstants.au3"
0.44 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\staticconstants.au3
0.44 ==> Start Add_Include: Include_Rec$:#include "TabConstants.au3"
0.44 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\tabconstants.au3
0.44 ==> Start Add_Include: Include_Rec$:#include "TreeViewConstants.au3"
0.44 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\treeviewconstants.au3
0.45 ==> Start Add_Include: Include_Rec$:#include "UpDownConstants.au3"
0.45 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\updownconstants.au3
0.45 ==> Start Add_Include: Include_Rec$:#include "WindowsConstants.au3"
0.45 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\windowsconstants.au3
0.48 ==> Start Add_Include: Include_Rec$:#include <File.au3>
0.48 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\file.au3
0.48 ==> Start Add_Include: Include_Rec$:#include "Array.au3"
0.48 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\array.au3
0.53 ==> Start Add_Include: Include_Rec$:#include "FileConstants.au3"
0.53 ==> Skipped, Already included:"FileConstants.au3"
0.53 ==> Start Add_Include: Include_Rec$:#include "StringConstants.au3"
0.53 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\stringconstants.au3
0.55 ==> Start Add_Include: Include_Rec$:#include <String.au3>
0.55 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\string.au3
0.56 ==> Start Add_Include: Include_Rec$:#include <VT.au3>
0.56 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\vt.au3
0.56 ==> Start Add_Include: Include_Rec$:#include "WinHttp.au3"
0.56 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\winhttp.au3
0.56 ==> Start Add_Include: Include_Rec$:#include "WinHttpConstants.au3"
0.56 ==> Loading Include file into source Array:c:\program files (x86)\autoit3\include\winhttpconstants.au3
!Include file contains records longer than 2047 which is the max when Obfuscating .. stopping process.
C:\Program Files (x86)\AutoIt3\include\WinHttp.au3(1945,1) Return ";ai|application/postscript;aif|audio/x-aiff;aifc|audio/x-aiff;aiff|audio/x-aiff;asc|text/plain;atom|application/atom+xml;au|audio/basic;avi|video/x-msvideo;bcpio|application/x-bcpio;bin|application/octet-stream;bmp|image/bmp;cdf|application/x-netcdf;cgm|image/cgm;class|application/octet-stream;cpio|application/x-cpio;cpt|application/mac-compactpro;csh|application/x-csh;css|text/css;dcr|application/x-director;dif|video/x-dv;dir|application/x-director;djv|image/vnd.djvu;djvu|image/vnd.djvu;dll|application/octet-stream;dmg|application/octet-stream;dms|application/octet-stream;doc|application/msword;dtd|application/xml-dtd;dv|video/x-dv;dvi|application/x-dvi;dxr|application/x-director;eps|application/postscript;etx|text/x-setext;exe|application/octet-stream;ez|application/andrew-inset;gif|image/gif;gram|application/srgs;grxml|application/srgs+xml;gtar|application/x-gtar;hdf|application/x-hdf;hqx|application/mac-binhex40;htm|text/html;html|text/html;ice|x-conference/x-cooltalk;ico|image/x-icon;ics|text/calendar;ief|image/ief;ifb|text/calendar;iges|model/iges;igs|model/iges;jnlp|application/x-java-jnlp-file;jp2|image/jp2;jpe|image/jpeg;jpeg|image/jpeg;jpg|image/jpeg;js|application/x-javascript;kar|audio/midi;latex|application/x-latex;lha|application/octet-stream;lzh|application/octet-stream;m3u|audio/x-mpegurl;m4a|audio/mp4a-latm;m4b|audio/mp4a-latm;m4p|audio/mp4a-latm;m4u|video/vnd.mpegurl;m4v|video/x-m4v;mac|image/x-macpaint;man|application/x-troff-man;mathml|application/mathml+xml;me|application/x-troff-me;mesh|model/mesh;mid|audio/midi;midi|audio/midi;mif|application/vnd.mif;mov|video/quicktime;movie|video/x-sgi-movie;mp2|audio/mpeg;mp3|audio/mpeg;mp4|video/mp4;mpe|video/mpeg;mpeg|video/mpeg;mpg|video/mpeg;mpga|audio/mpeg;ms|application/x-troff-ms;msh|model/mesh;mxu|video/vnd.mpegurl;nc|application/x-netcdf;oda|application/oda;ogg|application/ogg;pbm|image/x-portable-bitmap;pct|image/pict;pdb|chemical/x-pdb;pdf|application/pdf;pgm|image/x-portable-graymap;pgn|application/x-chess-pgn;pic|image/pict;pict|image/pict;png|image/png;pnm|image/x-portable-anymap;pnt|image/x-macpaint;pntg|image/x-macpaint;ppm|image/x-portable-pixmap;ppt|application/vnd.ms-powerpoint;ps|application/postscript;qt|video/quicktime;qti|image/x-quicktime;qtif|image/x-quicktime;ra|audio/x-pn-realaudio;ram|audio/x-pn-realaudio;ras|image/x-cmu-raster;rdf|application/rdf+xml;rgb|image/x-rgb;rm|application/vnd.rn-realmedia;roff|application/x-troff;rtf|text/rtf;rtx|text/richtext;sgm|text/sgml;sgml|text/sgml;sh|application/x-sh;shar|application/x-shar;silo|model/mesh;sit|application/x-stuffit;skd|application/x-koan;skm|application/x-koan;skp|application/x-koan;skt|application/x-koan;smi|application/smil;smil|application/smil;snd|audio/basic;so|application/octet-stream;spl|application/x-futuresplash;src|application/x-wais-source;sv4cpio|application/x-sv4cpio;sv4crc|application/x-sv4crc;svg|image/svg+xml;swf|application/x-shockwave-flash;t|application/x-troff;tar|application/x-tar;tcl|application/x-tcl;tex|application/x-tex;texi|application/x-texinfo;texinfo|application/x-texinfo;tif|image/tiff;tiff|image/tiff;tr|application/x-troff;tsv|text/tab-separated-values;txt|text/plain;ustar|application/x-ustar;vcd|application/x-cdlink;vrml|model/vrml;vxml|application/voicexml+xml;wav|audio/x-wav;wbmp|image/vnd.wap.wbmp;wbmxl|application/vnd.wap.wbxml;wml|text/vnd.wap.wml;wmlc|application/vnd.wap.wmlc;wmls|text/vnd.wap.wmlscript;wmlsc|application/vnd.wap.wmlscriptc;wrl|model/vrml;xbm|image/x-xbitmap;xht|application/xhtml+xml;xhtml|application/xhtml+xml;xls|application/vnd.ms-excel;xml|application/xml;xpm|image/x-xpixmap;xsl|application/xml;xslt|application/xslt+xml;xul|application/vnd.mozilla.xul+xml;xwd|image/x-xwindowdump;xyz|chemical/x-xyz;zip|application/zip;"
!Ending Obfuscator program.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Jos

  • Resolution set to Wont Fix
  • Status changed from new to closed

Support for Obfuscator has stopped.
Also think the log file is pretty clear what the problem is.
Assume you are the same person that pmed me this without any question or context.

Jos

comment:2 Changed 6 years ago by guinness

If the user PMs me I will send them an update of that function.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.