Modify

Opened 6 years ago

Closed 6 years ago

#2650 closed Bug (Fixed)

_FileListToArrayRec returns an extra row in array with number of Files/Folders returned

Reported by: itaushanov@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.10.2 Severity: None
Keywords: Cc:

Description

Simple script:

#include <File.au3>
#include <Array.au3>
$f = "D:\Torrents\DP_WLAN_12.03_NT6\"
$aFileList =_FileListToArrayRec ($f, "*.inf", 1+4+8, 1, 1, 2 )
_ArrayDisplay($aFileList)

This returns:
Row|Col 0
[0]|133
[1]|133
[2]|D:\Torrents\DP_WLAN_12.03_NT6\x64\All\W\Atheros\1\netathrx.inf
[3]|D:\Torrents\DP_WLAN_12.03_NT6\x64\All\W\Atheros\2\netathrx.inf
[4]|D:\Torrents\DP_WLAN_12.03_NT6\x64\All\W\Broadcom\1\bcmwl6.inf
[5]|D:\Torrents\DP_WLAN_12.03_NT6\x64\All\W\Broadcom\2\bcmwl6.inf
[6]|D:\Torrents\DP_WLAN_12.03_NT6\x64\All\W\Broadcom\3\bcmwl6.inf
......

Note row 1, it's a duplicate of row 0.

Without sorting ($f, "*.inf", 1+4+8, 1, 0, 2 ) result is fine.

Result of dir /s /b is here:
http://pastebin.com/F1uBTafd

Contents of DP_WLAN_12.03_NT6 are these two files extracted in it:
http://driverpacks.net/driverpacks/windows/7/x64/wlan/12.03
http://driverpacks.net/driverpacks/windows/7/x86/wlan/12.03

Tested with _FileListToArrayRec from the latest beta 3.3.11.3- same result.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by Melba23

Using that file structure I can reproduce the problem with 3.3.10.2, but 3.3.11.3 gives me the correct result as the bug which caused the problem was fixed (by me) in revision 9156.

I have just downloaded the 3.3.11.3 zip and the fix is definitely in place in File.au3 so are you sure that you are actually running 3.3.11.3?

M23

comment:2 Changed 6 years ago by guinness

I am not getting any issue either.

comment:3 Changed 6 years ago by itaushanov@…

You are right, issue seems fixed in 3.3.11.3.

comment:4 Changed 6 years ago by Melba23

Good.

M23

comment:5 Changed 6 years ago by Melba23

  • Resolution set to Fixed
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.