Modify

Opened 5 years ago

Closed 5 years ago

#2767 closed Bug (No Bug)

'Attempt to access invalid address' in some cases when using #AutoIt3Wrapper_Res_requestedExecutionLevel=RequireAdministrator

Reported by: anonymous Owned by: Jos
Milestone: Component: SciTE4AutoIt
Version: Other Severity: None
Keywords: Cc: remco.timmermans@…

Description

Hi,

Under some circumstances you get the error message 'Attempt to access invalid address' when running the compiled .exe.

Sample code

 #AutoIt3Wrapper_Res_requestedExecutionLevel=RequireAdministrator

To reproduce

  • Tested with Windows 7 PRO SP1
  • enable UAC (requires reboot if not enabled)
  • Map a network share to a driveletter
  • run the compiled .exe from that network drive
  • you get the error message

If UAC is not enabled you will not get the error.
If you run the .exe local or from unc path with UAC enabled you also will not get the error

I think that's al you need, if you need anything else please let me know.

Kind regards

Remco

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Jos

  • Component changed from AutoIt to SciTE4AutoIt
  • Owner set to Jos
  • Version changed from 3.3.12.0 to Other

Hi Remco,

AutoIt3Wrapper will only update the Program's PE header manifest with the requested level, so am not sure how this could be an bug with AutoiT3 or AutoIt3Wrapper.
What version of AutoIt3Wrapper are you using? (is displayed in the SciTE console when you do a compile)
Thoughts?

Jos

Last edited 5 years ago by Jos (previous) (diff)

comment:2 Changed 5 years ago by anonymous

Hi Jos,

AutoIt3Wrapper version is 2.2.0.3

But since you stated you are not sure if this is an AutoIt3 issue I did some additional tests.
When starting other program's (auto it installer, java installer) from that network drive with UAC enabled I get the same error.
So you are correct that this is not a specific autoit bug. It seems like a windows/UAC bug.
Not sure though where to report this one...

Anyway, thanks for taking the time to look into it!

Kind regards

Remco

comment:3 Changed 5 years ago by Jos

  • Resolution set to No Bug
  • Status changed from new to closed

You're welcome.

Jos

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.