Modify

Opened 6 years ago

Closed 6 years ago

#2930 closed Bug (No Bug)

Wrong CheckBox position for ListView

Reported by: mike2003 Owned by:
Milestone: Component: AutoIt
Version: 3.3.13.19 Severity: None
Keywords: Cc:

Description

I found that if i change the font size, the CheckBox position look wrong. like they are between the lines.
this is confusing...
CheckBox alignment should be at the center or on the bottom, but not on top of the text.

All good for $LVS_REPORT - checkbox in center of line.
But wrong for $LVS_LIST or $LVS_SMALLICON

Some pictures (example) are here:
http://www.autoitscript.com/forum/topic/165471-fix-checkbox-position-for-listview/

#include <GUIConstantsEx.au3>
#include <ListViewConstants.au3>
#include <WindowsConstants.au3>

$Form1 = GUICreate("Form1", 615, 438, 192, 124)
$ListView1 = GUICtrlCreateListView("", 40, 32, 457, 297, BitOR($GUI_SS_DEFAULT_LISTVIEW,$LVS_LIST), BitOR($WS_EX_CLIENTEDGE,$LVS_EX_CHECKBOXES))
GUICtrlSetFont(-1, 20, 400, 0, "MS Sans Serif")
$ListView1_0 = GUICtrlCreateListViewItem("aaaaaa", $ListView1)
$ListView1_1 = GUICtrlCreateListViewItem("bbbbbbbb", $ListView1)
$ListView1_2 = GUICtrlCreateListViewItem("ccccccccc", $ListView1)
$ListView1_3 = GUICtrlCreateListViewItem("dddddddddd", $ListView1)
$ListView1_4 = GUICtrlCreateListViewItem("eeeeeeeee", $ListView1)
GUISetState(@SW_SHOW)

While 1
    $nMsg = GUIGetMsg()
    Switch $nMsg
        Case $GUI_EVENT_CLOSE
            Exit

    EndSwitch
WEnd

Attachments (2)

cb-pos.jpg (16.2 KB) - added by anonymous 6 years ago.
cb-pos2.jpg (13.2 KB) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by anonymous

Changed 6 years ago by anonymous

comment:1 Changed 6 years ago by bogQ

hes is not using icons that he should be using, added sloppy example on his original topic.

comment:2 Changed 6 years ago by Melba23

  • Resolution set to No Bug
  • Status changed from new to closed

The problem is not of AutoIt's making - you are using an icon view without icons. If you use icons as shown in bogQ's example you get centred checkboxes.

M23

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.