Modify

Opened 6 years ago

Closed 6 years ago

#2931 closed Bug (Wont Fix)

_ExcelRangeFind helpfile example doesn't work with v. 3.3.13.19 beta

Reported by: gcriaco Owned by:
Milestone: Component: AutoIt
Version: 3.3.13.19 Severity: None
Keywords: Cc:

Description

here is what happens with latest beta:

Running:(3.3.13.19):C:\Program Files (x86)\AutoIt3\Beta\autoit3_x64.exe "C:\Program Files (x86)\AutoIt3\Beta\Examples\Helpfile\_Excel_RangeFind[2].au3"

--> Press Ctrl+Alt+Break to Restart or Ctrl+Break to Stop
"C:\Program Files (x86)\AutoIt3\Beta\Include\Excel.au3" (608) : ==> The requested action with this object has failed.:
$aResult[$iIndex][1] = $oMatch.Name.Name
$aResult[$iIndex][1] = $oMatch ERROR
->13:56:11 AutoIt3.exe ended.rc:1
+>13:56:11 AutoIt3Wrapper Finished.

Exit code: 1 Time: 1.67

Anything is OK with latest stable version:

Running:(3.3.12.0):C:\Program Files (x86)\AutoIt3\autoit3_x64.exe "C:\Program Files (x86)\AutoIt3\Beta\Examples\Helpfile\_Excel_RangeFind[2].au3"

--> Press Ctrl+Alt+Break to Restart or Ctrl+Break to Stop
+>13:53:36 AutoIt3.exe ended.rc:0
+>13:53:36 AutoIt3Wrapper Finished.

Exit code: 0 Time: 8.371

Best regards
Peppe

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by water

This is caused by the way COM errors are handled in the latest beta version.
As the beta is still under heavy development things might change again with the next stable.
So this is not a bug but a temporary problem.

comment:2 Changed 6 years ago by water

  • Resolution set to Wont Fix
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.