Modify

Opened 4 years ago

Closed 4 years ago

#3155 closed Bug (No Bug)

_Excel_RangeWrite with $bForceFunc=True doesn't transpose array

Reported by: gcriaco@… Owned by:
Milestone: Component: Standard UDFs
Version: 3.3.14.2 Severity: None
Keywords: Cc:

Description

Setting the $bForceFunc parameter to True doesn't transpose an array on the Excel sheet. See the help example 1 (_Excel_RangeWrite.au3): changing bForceFunc=True doesn't change:

_Excel_RangeWrite($oWorkbook, $oWorkbook.Activesheet, $aArray1D, "A3",True, True)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by guinness

  • Component changed from AutoIt to Standard UDFs

comment:2 Changed 4 years ago by BrewManNH

  • Resolution set to No Bug
  • Status changed from new to closed

What are you expecting it to do with that set to true?

It's only used to tell the UDF to use the _ArrayTranspose function instead of the Excel $oExcel.Transpose function. Furthermore, it's not going to change the output to Excel by setting it true or false. Regardless of the setting, the array is being transposed, it just uses different methods to do that according to the setting.

Not a bug, but a misunderstanding of the function.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.