Modify

Opened 4 years ago

Closed 4 years ago

#3185 closed Bug (Duplicate)

Multiple FileInstall not working

Reported by: anonymous Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.2 Severity: None
Keywords: Cc:

Description

If FileInstall("fileA1", "fileA2") And FileInstall("fileB1", "fileB2") Then
   MsgBox(0,"installation","completed")
Else
   MsgBox(0,"installation","error")
EndIf

This code works only in the not compiled version. In the compiled version the first file will be installed and the second will fail. The program has administrator rights and the files do not exist previously. If FileInstall is not desigend using it twice in one line please add a comment in the documentation. Otherwise it is a bug in the compiler, because the second file is "ignored" by the including routine.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Jos

  • Resolution set to Duplicate
  • Status changed from new to closed

Duplicate of close report #3183.
In case you do not agre come to our forum to have the dialogue about it.

Jos

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.