Modify

Opened 4 years ago

Closed 4 years ago

#3189 closed Bug (No Bug)

"Run" and "RunWait" functions call an A3X multiple times with an compiled file

Reported by: phongkhanhbinh@… Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.0 Severity: None
Keywords: Cc:

Description

Hi team,

I got a critical issue with these step below

  1. Create a new file named "wait.au3"
sleep(1000)

  1. Compile "wait.au3" to "wait.a3x"
  1. Create a new file named "main.au3"
Run(@AutoItExe & ' wait.a3x')

  1. Try to test the "main.au3" script from SciTE. The result is passed.
  1. Compile "main.au3" to "main.exe"
  1. Execute "main.exe"

Observed: the process calls "wait.a3x" multiple times until the RAM is run out of space (my machine has 08 GB RAM)

Expected: this process will run like we have tried on SciTE.

I have tried to add "/AutoIt3ExecuteScript" to "main.au3", then everything is good.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Jos

  • Resolution set to No Bug
  • Status changed from new to closed

This is not a bug but expected behavioras @AutoItExe will be AutoIt3.exe when run from SciTE but will be Main.exe when compiled. When doing a Run("Main.exe wait.a3x") then simply main is run which again runs itself.

Please come to our forums irst to discuss your issues before posting it as a Bug as it might very well be a pilot error. :)

Jos

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.