Modify

Opened 4 years ago

Closed 22 months ago

#3192 closed Bug (No Bug)

Regression with reference

Reported by: guinness Owned by:
Milestone: Component: AutoIt
Version: 3.3.14.0 Severity: None
Keywords: Cc:

Description

The following snippet causes an error to be invoked, though does not occur in older versions of AutoIt prior to v3.3.12.0. According to Jos, this occurred in Rev 10373 made for v3.3.13.7.

    Local $aArray[] = [99, 100, $aArray[0]] ; => 99, 100, 99

URL: https://www.autoitscript.com/forum/topic/179627-array-declaration-error-new-behavior-can-not-initialize-a-variable-with-itself/?page=2#comment-1289279

Attachments (0)

Change History (2)

comment:1 Changed 23 months ago by Jpm

It seems the "regression" was introduced in 3.3.13.5 due to 10345

For me is not good to reference a non declared var
So $aArray[0] is not declared so I think the definition of "Local $aArray[]" is a problem as the array is not defined

So for me before 3.3.13.5 was wrong, I propose to close "No Bug"

comment:2 Changed 22 months ago by Jpm

  • Resolution set to No Bug
  • Status changed from new to closed

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.