Modify

Opened 4 years ago

Closed 4 years ago

#3191 closed Bug (No Bug)

SciTE Won't save hidden scripts.

Reported by: BetaLeaf Owned by: Jos
Milestone: Component: SciTE4AutoIt
Version: Other Severity: None
Keywords: Cc:

Description

SciTE V3.6.0
How to reproduce:

  1. Create any new AutoIt Script.
  2. In Folders, right click on the newly created script and click properties.
  3. Check the 'Hidden' checkbox. Click ok.
  4. Edit the script enough to make any change and enable saving.
  5. Press Ctrl+s to save.
  6. It will tell you it cannot save there and asks if you want to save elsewhere.
  7. Close SciTE.
  8. Repeat step 2.
  9. Uncheck the 'Hidden' checkbox. Click ok.
  10. Repeat steps 4 and 5. Notice it saves fine now.

The Hidden attribute is the problem. Checked prevents it from saving, unchecked allows saving. What?

Unrelated to this ticket, I develope AutoIt Scripts but I'm not a developer? Is that intended? Can I become Developer if it isn't?

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by BrewManNH

  • Resolution set to No Bug
  • Status changed from new to closed

The author of SciTE doesn't consider this to be a bug. This has been like this in SciTE since at least 2003 and Neil says he won't fix it as it's not considered to be a bug to him.
If you feel that this requires a bug ticket, I'd suggest heading over to the scintilla/scite website and posting it there.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jos.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.