Modify

Opened 12 years ago

Closed 12 years ago

#33 closed Bug (No Bug)

_IsNumber() & IsInt() both incorrectly return true

Reported by: squirrely1 Owned by:
Milestone: Component: AutoIt
Version: 3.2.10.0 Severity:
Keywords: Cc:

Description

XP SP2 EN x86

MsgBox(0,"Testing IsInt()",IsInt(Number("K")) & " - Should be: 0")
MsgBox(0,"Testing IsNumber()",IsNumber(Number("K")) & " - Should be: 0")

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by Valik

  • Resolution set to nobug
  • Status changed from new to closed

Break down what you're doing. You call Number("K") and it returns 0, which is a number. You then pass 0 to IsInt() or IsNumber(), both of which correctly return True since you gave it numeric input.

Not a bug.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.