Modify

Opened 12 years ago

Closed 12 years ago

#34 closed Bug (Works For Me)

Pixelchecksum returns wrong values

Reported by: stevy80@… Owned by: Jon
Milestone: Component: AutoItX
Version: 3.2.10.0 Severity:
Keywords: Cc:

Description

Hello,

I developed an application with visual c# under windows xp. This program uses autoitx3.dll. Everything worked fine until I upgraded the system. With the new cpu (64 bit) - still under xp - the pixelchecksum function (aprox. in the half of the cases) returns wrong values (-2147483648).

After this, I tried the program on two more machines with Intel P4 cpu, and the results was the same.

I tested the checksum at these machines with autoit main too, and that worked perfectly. So I think the problem is in autoitx.

Attachments (1)

AutoItXTest.au3 (757 bytes) - added by Valik 12 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 in reply to: ↑ description Changed 12 years ago by Jpm

Replying to stevy80@gmail.com:

Hello,

I developed an application with visual c# under windows xp. This program uses autoitx3.dll. Everything worked fine until I upgraded the system. With the new cpu (64 bit) - still under xp - the pixelchecksum function (aprox. in the half of the cases) returns wrong values (-2147483648).

After this, I tried the program on two more machines with Intel P4 cpu, and the results was the same.

I tested the checksum at these machines with autoit main too, and that worked perfectly. So I think the problem is in autoitx.

You have to know tha tautoitX3 have not be ported to X64. So certainly tou get a crash looks to me as the result of the -2147483648. Jon will confirm

Changed 12 years ago by Valik

comment:2 Changed 12 years ago by Valik

  • Resolution set to worksforme
  • Status changed from new to closed

With the above attached file, since you didn't provide one, it runs fine on 64-bit Windows running with 32-bit AutoIt/AutoItX. I'm marking this as works for me.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jon.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.