Modify

Opened 12 years ago

Closed 12 years ago

#331 closed Bug (Duplicate)

menuradioitem is not work?

Reported by: YGYL Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: GUICtrlCreateMenuItem Cc:

Description

menuradioitem is not work?

#include <GUIConstants.au3>

$Form1 = GUICreate("Form1", 633, 447, 193, 125)
$MenuItem2 = GUICtrlCreateMenu("MenuItem2")
$MenuItem1 = GUICtrlCreateMenu("MenuItem1")
$MenuItem3 = GUICtrlCreateMenuItem("MenuItem3", $MenuItem1, -1 , 1)
GUICtrlSetState(-1, $GUI_CHECKED)
$MenuItem4 = GUICtrlCreateMenuItem("MenuItem4", $MenuItem1, -1 , 1)
$MenuItem5 = GUICtrlCreateMenuItem("MenuItem5", $MenuItem1, -1 , 1)
GUISetState(@SW_SHOW)

While 1
    $nMsg = GUIGetMsg()
    Switch $nMsg
        Case $GUI_EVENT_CLOSE
            Exit
        Case $MenuItem4
            MsgBox(0,"2","")
            GUICtrlSetState($MenuItem4, $GUI_CHECKED)
    EndSwitch
WEnd

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by Ultima

comment:2 Changed 12 years ago by Valik

  • Resolution set to Duplicate
  • Status changed from new to closed

Closing as a Duplicate of #325.

Ultima, don't link tickets explicitly. Just type #<ticketnumber> and Trac will automagically link it. There are a couple reasons for this. First, you have now hard-coded a link to that ticket into the system. If we ever change URL's for the issue tracker, that link becomes invalid. Second, I use the secure (https) version of the issue tracker but you've linked to the non-secured (http) version. Not a big deal really, but still. Lastly, the ticket isn't striked-out to show that it's closed since it's just a normal link.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.