Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#352 closed Bug (Works For Me)

v3.2.12.0 + RegRead (REG_MULTI_SZ)

Reported by: Stéphane Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

if you try to read a REG_MULTI_SZ realy big key > 255 chars, RegRead returns nothing and @error is set to -2, smaller keys are read correctly

Attachments (0)

Change History (6)

comment:1 Changed 12 years ago by Jpm

can you give an example using an existing key in the registry?
Thanks

comment:2 Changed 12 years ago by Jpm

$keyname = "HKCU\Test"
$value="1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890" & @LF
$value&="1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890"
$value&="1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890"
$value&="1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890"
$RegWrite = RegWrite($keyname,"RegMultiSz","REG_MULTI_SZ",$value)
$RegRead = RegRead($keyname,"RegMultiSz")
MsgBox(262144,'Debug line ~' & @ScriptLineNumber,'Selection:' & @lf & '$RegRead' & @lf & @lf & 'Return:' & @lf & $RegRead & @lf & @lf & '@Error:' & @lf & @Error) ;### Debug MSGBOX
$RegDelete = RegDelete($keyname)

That's working perfect under Vista SP1. So you understand that" you need to follow directive as how to write a bug ticket

comment:3 follow-up: Changed 12 years ago by Jon

I think we limit reg operations to 64KB. Might be worth rewriting/checking if this is the case.

comment:4 in reply to: ↑ 3 Changed 12 years ago by Jpm

Replying to Jon:

I think we limit reg operations to 64KB. Might be worth rewriting/checking if this is the case.

So that's nothing to do with a 255 char limit ...

comment:5 Changed 12 years ago by Valik

  • Resolution set to Works For Me
  • Status changed from new to closed

Your report is confusing. Here's what I can say.

If you really do mean "key", then yes, a limit of 255 is correct. Each key name can only be 255 characters. The full path can be longer than 255 characters but any one individual key name can only be 255 characters. This does not appear to be a bug, although I can't find mention in a quick scan of MSDN.

If you mean the size of the data a value can hold, then it's definitely not limited at 255. Since you mention REG_MULTI_SZ, you may be experiencing an issue with an improperly formatted data. This would not be an AutoIt bug, either.

Without a proper script to reproduce the issue and without clarification of the terminology which is rather critical, there's nothing to do but close this as works for me. I tried a few things and could not reproduce what you describe.

comment:6 Changed 12 years ago by Valik

Alright, I found the registry size limits which confirm what I said:
http://msdn.microsoft.com/en-us/library/ms724872(VS.85).aspx

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.