Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#353 closed Bug (No Bug)

Aut2exe adding weird blank icons to compiled apps

Reported by: corz Owned by:
Milestone: Component: Aut2Exe
Version: 3.2.12.0 Severity: None
Keywords: Aut2exe compile id icon blank Cc:

Description

I have recently upgraded my AutoIt installation (from 3.2.9.3b to 3.2.12.0) and I've discovered what looks like a bug in Aut2exe; it's adding blank 16x16x16 icons into the compiled application, at id#2 (after the main application icon).

If other icons are added to the application, e.g. document icons (with AutoIt3Wrapper) their id's are shifted up by one, and the document icon (or whatever) appears incorrectly on the user's system - in a defaulticon registry setting, for example, but it's true of any place that might reference one of the application's icons by its standard windows id.

I guessed it might be a lack of 16x16x16 format icon in my own application icons, but even using Aut2exe without AutoIt3Wrapper and no compile option whatsoever, this extra blank icon appears, and the AutoIt default icon has the 16x16x16 format, so that's not the reason, not that that would be a good reason!

I've searched the forum, documentation and history, and I can't find any mention of this extra icon's purpose, other than to mess up all the icon id's. Is this a bug?

I don't want to go implementing changes to my application's installers to fix all these references to something that's just going to be fixed back again. If it's going to be fixed, I could instead temporarily remove this weird blank icon from compiled applications until it's fixed, which though a pain (I always have to go into ResHacker anyway), would be preferable for end-users.

;o)
(or

Attachments (0)

Change History (5)

comment:1 Changed 12 years ago by anonymous

Actually, removing icons from compiled applications isn't so easy. I've just tried three tools that I expected to be able to do it, and none of them could. Oh oh.

comment:2 Changed 12 years ago by Valik

  • Resolution set to No Bug
  • Status changed from new to closed

It is in fact an intentional change. However, no matter what, it is not a bug. AutoIt does not officially support modifying resources. You are using 2nd- and 3rd-party tools to add your own icons. It is not our responsibility to fix this because we did not break anything we officially support. If you choose to add resources to your compiled scripts, then the onus is on you to maintain your script to correctly reference them.

comment:3 Changed 12 years ago by Queue

The blank icon is used to make the tray icon blink when TraySetState(4) is used. The icon is swapped back and forth between the standard icon (which can be changed via TraySetIcon()) and the blank icon.

comment:4 follow-up: Changed 12 years ago by corz

I see. So long as it's staying that way, I can simply update the references, no problem. Cheers.

In future, such important changes could perhaps be noted in the change log, so folk know it's intentional.

;o)
(or

ps. I didn't realize AutoIt3Wrapper was an unsupported 3rd party tool. I got it from the downloads page. Noted, thanks. At any rate, Valik, I could have been using the built-in "+" icon for some purpose, and without any 3rd party tools whatsoever, it would now be broken. I don't mind fixing it, I just wanted to be sure that my fix wouldn't also break.

comment:5 in reply to: ↑ 4 Changed 12 years ago by Valik

Replying to corz:

I see. So long as it's staying that way, I can simply update the references, no problem. Cheers.

In future, such important changes could perhaps be noted in the change log, so folk know it's intentional.

I believe it is documented, it just doesn't mention the new icon because that is an implementation detail. While to you it seems an important point, keep in mind, as I said, you are doing things that aren't officially supported.

ps. I didn't realize AutoIt3Wrapper was an unsupported 3rd party tool. I got it from the downloads page. Noted, thanks. At any rate, Valik, I could have been using the built-in "+" icon for some purpose, and without any 3rd party tools whatsoever, it would now be broken. I don't mind fixing it, I just wanted to be sure that my fix wouldn't also break.

It's a semi-supported, semi-official 2nd party tool.

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.