Modify

Opened 11 years ago

Closed 11 years ago

#355 closed Bug (Fixed)

Child dialogs not visible

Reported by: Ultima Owned by: Jpm
Milestone: 3.2.13.1 Component: AutoIt
Version: 3.2.13.0 Severity: None
Keywords: Cc:

Description

Global $hParent = GUICreate("Parent", 320, 240)
Global $hChild = GUICreate("Child", 200, 150, Default, Default, Default, Default, $hParent)

GUISetState(@SW_SHOW, $hParent)
GUISetState(@SW_SHOW, $hChild)

Do
Until GUIGetMsg() = -3

Expected behavior: The child dialog should be displayed
Observed behavior: The child dialog is completely missing

Attachments (0)

Change History (6)

comment:1 Changed 11 years ago by Valik

Very strange. I can see the non-client area (though this may be because I'm using WindowBlinds). The client area is fully transparent. The child appears to the lower right of the parent by quite a bit. It also won't let me move the mouse outside the client area of the parent while I'm dragging the child. I can drag the child around but I'm bound by the client area of the parent.

comment:3 Changed 11 years ago by Jon

Odd, this works:

Global $hParent = GUICreate("Parent", 320, 240)

GUISetState(@SW_SHOW, $hParent)
Global $hChild = GUICreate("Child", 200, 150, Default, Default, Default, Default, $hParent)
GUISetState(@SW_SHOW, $hChild)

Do
Until GUIGetMsg() = -3

I know jp/us mess around with GuiSetState almost every build so we've probably messed up something.

comment:4 Changed 11 years ago by anonymous

Jon's posted code doesn't work for me in beta .13.0

comment:5 Changed 11 years ago by Gary

Jon your code doesn't work correctly for me in 3.2.13.0 on WinXP Pro SP3. Child window still doesn't show.

comment:6 Changed 11 years ago by Jpm

the regression is due to rev 3456

comment:6 Changed 11 years ago by Jpm

  • Milestone set to 3.2.13.1
  • Owner set to Jpm
  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in version: 3.2.13.1

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The owner will remain Jpm.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.