Modify

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#356 closed Bug (No Bug)

ConsoleWrite not working on Vista.

Reported by: Tlem Owned by:
Milestone: Component: AutoIt
Version: 3.2.12.0 Severity: None
Keywords: Cc:

Description

Perhaps I made something wrong, but on Vista this code doesn't work :

Local $var = "Test"
ConsoleWrite("var=" & $var & @CRLF)

Even if I try other writing methods ...
If I put #RequireAdmin it doesn't work anymore ...
It will be probably necessery to have a look on all consolexxx command on Vista and Windows 2008.

I Don't know if it's AutoIt or Scite4AutoIt !!!

Tanks for your work

Attachments (0)

Change History (7)

comment:1 in reply to: ↑ description Changed 12 years ago by Valik

Replying to Tlem:

It will be probably necessery to have a look on all consolexxx command on Vista and Windows 2008.

Why? I can't rule out you being the problem. Here's why: You haven't told us how you're running this. Are you compiling it as a console application? Are you running it from within SciTE? Are you running it outside SciTE? And if you're using #RequireAdmin, then I can guarantee you're not going to see the output due to how it works and that is *not* a bug.

In short, you haven't provided enough information.

comment:2 Changed 12 years ago by anonymous

I see this 'bug' when I use Scite4AutoIt (Like I said before).
So the script isn't compiled, I just do F5 in Scite4AutoIt.

On Scite4AutoIt there is a result output where you can see various informations.
On Vista with the code of the example the output stream not appear on result windows of Scite4AutoIt !

comment:3 Changed 12 years ago by anonymous

You won't be able to see the console output if #RequireAdmin forces an elevation (secure desktop, click continue). This is by design. If you run Scite elevated (right click, run as admin) then everything will probably work ok.

comment:4 Changed 12 years ago by anonymous

It's ok.
Scite was open with the right clic Edit Script, so it wasn't lauch whith admin right. :(

Sorry for that.

I thank you very much, because you learn me that if I use Scite without launching him with admin right, he doesn't return output stream !!!
Note for Scite4AutoIt autors : It will be a pretty good idea to add a context menu for Vista like : Edit With Admin Right (I don't know if it's possible for the moment but I will probably search to make it ;) ).

You can close the ticket.

comment:5 Changed 12 years ago by Jon

  • Resolution set to No Bug
  • Status changed from new to closed

comment:6 Changed 11 years ago by Triblade

P.S.
Not also does the ConsoleWrite not work when Scite is not run with elevated rights, also the F5-run error's won't show in the console.
Maybe there is a way to show that this is a problem? Anyway, probs a Scite thing...

comment:7 Changed 11 years ago by Valik

As I said previously, not enough information has been provided. I just took a virgin installation of Windows Vista SP1 and installed AutoIt 3.3.0.0, AutoIt 3.3.1.0 (Beta) and SciTE4AutoIt3 (released 21-5-2009). I installed everything with elevated rights. I run everything without elevated rights. Using both SciTE-Lite (included with AutoIt) and SciTE4AutoIt3 with the simple test script below, everything worked as expected:

ConsoleWrite("Test" & @CRLF)

Guidelines for posting comments:

  • You cannot re-open a ticket but you may still leave a comment if you have additional information to add.
  • In-depth discussions should take place on the forum.

For more information see the full version of the ticket guidelines here.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.